|
From 5370c6774a333b2b3989639275d4093fdc541db9 Mon Sep 17 00:00:00 2001
|
|
From: Bertrand Jacquin <bertrand@jacquin.bzh>
|
|
Date: Thu, 6 Oct 2016 00:32:39 +0100
|
|
Subject: [PATCH 23/26] MINOR: build: Allow linking to device-atlas library
|
|
file
|
|
|
|
DeviceAtlas might be installed in a location where a user might not have
|
|
enough permissions to write json.o and dac.o
|
|
(cherry picked from commit 3a2661d6b4218704c828c8a712c87d651bfe29b5)
|
|
---
|
|
Makefile | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 1d0f2bc..0242cae 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -615,8 +615,12 @@ endif
|
|
DEVICEATLAS_SRC =
|
|
DEVICEATLAS_INC = $(DEVICEATLAS_SRC)
|
|
DEVICEATLAS_LIB = $(DEVICEATLAS_SRC)
|
|
+ifeq ($(DEVICEATLAS_SRC),)
|
|
+OPTIONS_LDFLAGS += -lda
|
|
+else
|
|
OPTIONS_OBJS += $(DEVICEATLAS_LIB)/json.o
|
|
OPTIONS_OBJS += $(DEVICEATLAS_LIB)/dac.o
|
|
+endif
|
|
OPTIONS_OBJS += src/da.o
|
|
OPTIONS_CFLAGS += -DUSE_DEVICEATLAS $(if $(DEVICEATLAS_INC),-I$(DEVICEATLAS_INC))
|
|
BUILD_OPTIONS += $(call ignore_implicit,USE_DEVICEATLAS)
|
|
--
|
|
2.7.3
|
|
|