You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

14 lines
570 B

--- zeromq-4.0.4_org/configure.ac 2014-06-04 10:19:35.140061796 +0800
+++ zeromq-4.0.4/configure.ac 2014-06-04 11:08:17.231997926 +0800
@@ -127,8 +127,10 @@
*linux*)
# Define on Linux to enable all library features. Define if using a gnu compiler
if test "x$GXX" = "xyes"; then
- CPPFLAGS="-D_GNU_SOURCE $CPPFLAGS"
+ CPPFLAGS="-D_GNU_SOURCE $CPPFLAGS -Wno-long-long"
fi
+ libzmq_pedantic="no"
+ libzmq_werror="no"
AC_DEFINE(ZMQ_HAVE_LINUX, 1, [Have Linux OS])
libzmq_on_linux="yes"