|
BASH PATCH REPORT
|
|
=================
|
|
|
|
Bash-Release: 5.1
|
|
Patch-ID: bash51-001
|
|
|
|
Bug-Reported-by: Fazal Majid <fazal@majid.org>
|
|
Bug-Reference-ID: <DEAB7D2C-C626-450C-B2E5-281AFF2D26D4@majid.org>
|
|
Bug-Reference-URL: https://lists.gnu.org/archive/html/bug-bash/2020-12/msg00000.html
|
|
|
|
Bug-Description:
|
|
|
|
There is a missing dependency on a constructed file, which can cause highly
|
|
parellel builds to fail.
|
|
|
|
Patch (apply with `patch -p0'):
|
|
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -1315,6 +1315,7 @@ bashline.o: trap.h flags.h assoc.h $(BAS
|
|
bashline.o: $(DEFSRC)/common.h $(GLOB_LIBSRC)/glob.h alias.h
|
|
bashline.o: pcomplete.h ${BASHINCDIR}/chartypes.h input.h
|
|
bashline.o: ${BASHINCDIR}/shmbutil.h ${BASHINCDIR}/shmbchar.h
|
|
+bashline.o: ${DEFDIR}/builtext.h
|
|
bracecomp.o: config.h bashansi.h ${BASHINCDIR}/ansi_stdlib.h
|
|
bracecomp.o: shell.h syntax.h config.h bashjmp.h ${BASHINCDIR}/posixjmp.h
|
|
bracecomp.o: command.h ${BASHINCDIR}/stdc.h error.h
|
|
@@ -1435,6 +1436,7 @@ builtins/evalstring.o: quit.h unwind_pro
|
|
builtins/evalstring.o: dispose_cmd.h make_cmd.h subst.h externs.h
|
|
builtins/evalstring.o: jobs.h builtins.h flags.h input.h execute_cmd.h
|
|
builtins/evalstring.o: bashhist.h $(DEFSRC)/common.h pathnames.h
|
|
+builtins/evalstring.o: ${DEFDIR}/builtext.h
|
|
builtins/getopt.o: config.h ${BASHINCDIR}/memalloc.h
|
|
builtins/getopt.o: shell.h syntax.h bashjmp.h command.h general.h xmalloc.h error.h
|
|
builtins/getopt.o: variables.h arrayfunc.h conftypes.h quit.h ${BASHINCDIR}/maxpath.h unwind_prot.h dispose_cmd.h
|
|
--- a/builtins/Makefile.in
|
|
+++ b/builtins/Makefile.in
|
|
@@ -361,7 +361,7 @@ evalstring.o: $(topdir)/dispose_cmd.h $(
|
|
evalstring.o: $(topdir)/externs.h $(topdir)/jobs.h $(topdir)/builtins.h
|
|
evalstring.o: $(topdir)/flags.h $(topdir)/input.h $(topdir)/execute_cmd.h
|
|
evalstring.o: $(topdir)/bashhist.h $(srcdir)/common.h
|
|
-evalstring.o: $(topdir)/trap.h $(topdir)/redir.h ../pathnames.h
|
|
+evalstring.o: $(topdir)/trap.h $(topdir)/redir.h ../pathnames.h ./builtext.h
|
|
#evalstring.o: $(topdir)/y.tab.h
|
|
getopt.o: ../config.h $(BASHINCDIR)/memalloc.h
|
|
getopt.o: $(topdir)/shell.h $(topdir)/syntax.h $(topdir)/bashjmp.h $(topdir)/command.h
|
|
--- a/patchlevel.h
|
|
+++ b/patchlevel.h
|
|
@@ -1,6 +1,6 @@
|
|
/* patchlevel.h -- current bash patch level */
|
|
|
|
-/* Copyright (C) 2001-2016 Free Software Foundation, Inc.
|
|
+/* Copyright (C) 2001-2020 Free Software Foundation, Inc.
|
|
|
|
This file is part of GNU Bash, the Bourne Again SHell.
|
|
|
|
@@ -25,6 +25,6 @@
|
|
regexp `^#define[ ]*PATCHLEVEL', since that's what support/mkversion.sh
|
|
looks for to find the patch level (for the sccs version string). */
|
|
|
|
-#define PATCHLEVEL 0
|
|
+#define PATCHLEVEL 1
|
|
|
|
#endif /* _PATCHLEVEL_H_ */
|