--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1212,6 +1212,7 @@ AC_TYPE_OFF_T
|
|
AC_TYPE_PID_T
|
|
AC_TYPE_SIZE_T
|
|
AC_CHECK_MEMBERS([struct stat.st_rdev])
|
|
+AC_CHECK_MEMBERS([struct timespec.tv_sec],[],[],[[#include <time.h>]])
|
|
AC_HEADER_TIME
|
|
AC_STRUCT_TM
|
|
AC_C_VOLATILE
|
|
--- a/lib/include/hgfsUtil.h
|
|
+++ b/lib/include/hgfsUtil.h
|
|
@@ -53,13 +53,7 @@
|
|
# include <time.h>
|
|
# endif
|
|
# include "vm_basic_types.h"
|
|
-# if !defined _STRUCT_TIMESPEC && \
|
|
- !defined _TIMESPEC_DECLARED && \
|
|
- !defined __timespec_defined && \
|
|
- !defined sun && \
|
|
- !defined __FreeBSD__ && \
|
|
- !__APPLE__ && \
|
|
- !defined _WIN32
|
|
+# if !defined HAVE_STRUCT_TIMESPEC_TV_SEC
|
|
struct timespec {
|
|
time_t tv_sec;
|
|
long tv_nsec;
|