You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

18 lines
499 B

--- a/meson.build
+++ b/meson.build
@@ -390,12 +390,11 @@ if dl_dep.found()
endif
have_iconv = false
-if cc.has_function('iconv_open')
+iconv_dep = cc.find_library('iconv', required : false)
+have_iconv = iconv_dep.found()
+if not have_iconv and cc.has_function('iconv_open')
iconv_dep = dependency('', required : false)
have_iconv = true
-else
- iconv_dep = cc.find_library('iconv', required : false)
- have_iconv = iconv_dep.found()
endif
if have_iconv
cdata.set('HAVE_ICONV', 1)