|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -487,16 +487,9 @@ class PyBuildExt(build_ext):
|
|
return ['m']
|
|
|
|
def detect_modules(self):
|
|
- # Ensure that /usr/local is always used, but the local build
|
|
- # directories (i.e. '.' and 'Include') must be first. See issue
|
|
- # 10520.
|
|
- if not cross_compiling:
|
|
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
|
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
|
# only change this for cross builds for 3.3, issues on Mageia
|
|
if cross_compiling:
|
|
self.add_gcc_paths()
|
|
- self.add_multiarch_paths()
|
|
|
|
# Add paths specified in the environment variables LDFLAGS and
|
|
# CPPFLAGS for header and library files.
|