|
diff --git a/setup.py b/setup.py
|
|
index cbdeaf3..5154412 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -480,7 +480,8 @@ class PyBuildExt(build_ext):
|
|
add_dir_to_list(dir_list, directory)
|
|
|
|
if os.path.normpath(sys.prefix) != '/usr' \
|
|
- and not sysconfig.get_config_var('PYTHONFRAMEWORK'):
|
|
+ and not sysconfig.get_config_var('PYTHONFRAMEWORK') \
|
|
+ and not cross_compiling:
|
|
# OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework
|
|
# (PYTHONFRAMEWORK is set) to avoid # linking problems when
|
|
# building a framework with different architectures than
|