|
From 2163a630eb737b9afe3277dccf44070ef55dea12 Mon Sep 17 00:00:00 2001
|
|
From: Lucian Cristian <lucian.cristian@gmail.com>
|
|
Date: Fri, 13 Sep 2019 07:12:34 +0300
|
|
Subject: [PATCH] clippy: CARES fail only if !enable_clippy_only test for CARES
|
|
otherwise config will fail with conditional "CARES" not defined
|
|
|
|
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
|
|
---
|
|
configure.ac | 14 ++++++++------
|
|
1 file changed, 8 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 6c1b35b5f2..9f37b3e9a9 100755
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1452,6 +1452,12 @@ if test "x$enable_pcreposix" = "xyes"; then
|
|
fi
|
|
AC_SUBST([HAVE_LIBPCREPOSIX])
|
|
|
|
+dnl ##########################################################################
|
|
+dnl test "${enable_clippy_only}" != "yes"
|
|
+fi
|
|
+dnl END OF LARGE if block
|
|
+dnl ##########################################################################
|
|
+
|
|
dnl ------------------
|
|
dnl check C-Ares library
|
|
dnl ------------------
|
|
@@ -1462,12 +1468,6 @@ PKG_CHECK_MODULES([CARES], [libcares], [
|
|
])
|
|
AM_CONDITIONAL([CARES], [$c_ares_found])
|
|
|
|
-dnl ##########################################################################
|
|
-dnl test "${enable_clippy_only}" != "yes"
|
|
-fi
|
|
-dnl END OF LARGE if block
|
|
-dnl ##########################################################################
|
|
-
|
|
|
|
dnl ----------------------------------------------------------------------------
|
|
dnl figure out if domainname is available in the utsname struct (GNU extension).
|
|
@@ -1535,9 +1535,11 @@ case "$host_os" in
|
|
no)
|
|
;;
|
|
yes)
|
|
+ if test "${enable_clippy_only}" != "yes"; then
|
|
if test "$c_ares_found" != "true" ; then
|
|
AC_MSG_ERROR([nhrpd requires libcares. Please install c-ares and its -dev headers.])
|
|
fi
|
|
+ fi
|
|
NHRPD="nhrpd"
|
|
;;
|
|
*)
|