You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

14 lines
493 B

--- a/configure.ac
+++ b/configure.ac
@@ -148,8 +148,10 @@ case "${host_os}" in
*linux*)
# Define on Linux to enable all library features. Define if using a gnu compiler
if test "x$GXX" = "xyes"; then
- CPPFLAGS="-D_GNU_SOURCE $CPPFLAGS"
+ CPPFLAGS="-D_GNU_SOURCE $CPPFLAGS -Wno-long-long"
fi
+ libzmq_pedantic="no"
+ libzmq_werror="no"
AC_DEFINE(ZMQ_HAVE_LINUX, 1, [Have Linux OS])
libzmq_on_linux="yes"