--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -50,7 +50,7 @@ if (("${CMAKE_C_COMPILER_ID}" STREQUAL "GNU" OR "${CMAKE_C_COMPILER_ID}" MATCHES
|
|
ADD_DEFINITIONS(-std=c99)
|
|
ADD_DEFINITIONS(-pedantic)
|
|
# for strdup, setenv
|
|
- ADD_DEFINITIONS(-D_POSIX_C_SOURCE=200809)
|
|
+ ADD_DEFINITIONS(-D_GNU_SOURCE)
|
|
#http://gcc.gnu.org/wiki/Visibility
|
|
add_definitions(-fvisibility=hidden)
|
|
|