You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

16 lines
403 B

--- a/configure.ac
+++ b/configure.ac
@@ -386,10 +386,11 @@ fi
if test "x$debug" = xtrue; then
CPPFLAGS="-DDEBUG $CPPFLAGS"
- CFLAGS="-g $CFLAGS"
+ CFLAGS=$(echo "$CFLAGS" | sed 's/-g[0-9]*//')
+ CFLAGS="-g3 $CFLAGS"
else
CPPFLAGS="-DNDEBUG $CPPFLAGS"
- CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//')
+ CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//;s/-g[0-9]*//')
CFLAGS="-O3 -funroll-loops $CFLAGS"
fi