You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

65 lines
2.5 KiB

--- a/Makefile.config
+++ b/Makefile.config
@@ -67,7 +67,7 @@ ifeq ($(shell uname -s),SunOS)
endif
ifndef $(HAVE_LIB_AIO)
-HAVE_LIB_AIO = $(shell $(MAKE) $(MAKE_OPTS) TEST_LIBS=$(LIB_AIO) TEST_PROG=test-libaio have_test_prog)
+#HAVE_LIB_AIO = $(shell $(MAKE) $(MAKE_OPTS) TEST_LIBS=$(LIB_AIO) TEST_PROG=test-libaio have_test_prog)
ifeq ($(HAVE_LIB_AIO),1)
CONFIG_CFLAGS += -DHAVE_LIB_AIO
CONFIG_LDFLAGS += $(LIB_AIO)
@@ -76,7 +76,7 @@ endif
endif
ifndef $(HAVE_LIB_BSD)
-HAVE_LIB_BSD = $(shell $(MAKE) $(MAKE_OPTS) TEST_LIBS=$(LIB_BSD) TEST_PROG=test-libbsd have_test_prog)
+#HAVE_LIB_BSD = $(shell $(MAKE) $(MAKE_OPTS) TEST_LIBS=$(LIB_BSD) TEST_PROG=test-libbsd have_test_prog)
ifeq ($(HAVE_LIB_BSD),1)
CONFIG_CFLAGS += -DHAVE_LIB_BSD
CONFIG_LDFLAGS += $(LIB_BSD)
@@ -103,7 +103,7 @@ endif
endif
ifndef $(HAVE_LIB_SCTP)
-HAVE_LIB_SCTP = $(shell $(MAKE) $(MAKE_OPTS) TEST_LIBS=$(LIB_SCTP) TEST_PROG=test-libsctp have_test_prog)
+#HAVE_LIB_SCTP = $(shell $(MAKE) $(MAKE_OPTS) TEST_LIBS=$(LIB_SCTP) TEST_PROG=test-libsctp have_test_prog)
ifeq ($(HAVE_LIB_SCTP),1)
CONFIG_CFLAGS += -DHAVE_LIB_SCTP
CONFIG_LDFLAGS += $(LIB_SCTP)
@@ -178,7 +178,7 @@ endif
endif
ifndef $(HAVE_AIO_H)
-HAVE_AIO_H = $(shell $(MAKE) $(MAKE_OPTS) HEADER=aio.h have_header_h)
+#HAVE_AIO_H = $(shell $(MAKE) $(MAKE_OPTS) HEADER=aio.h have_header_h)
ifeq ($(HAVE_AIO_H),1)
CONFIG_CFLAGS += -DHAVE_AIO_H
$(info autoconfig: using aio.h)
@@ -2516,7 +2516,7 @@ endif
endif
ifndef $(HAVE_SETPROCTITLE)
-HAVE_SETPROCTITLE = $(shell $(MAKE) $(MAKE_OPTS) TEST_LIBS=$(LIB_BSD) TEST_PROG=test-setproctitle have_test_prog)
+#HAVE_SETPROCTITLE = $(shell $(MAKE) $(MAKE_OPTS) TEST_LIBS=$(LIB_BSD) TEST_PROG=test-setproctitle have_test_prog)
ifeq ($(HAVE_SETPROCTITLE),1)
CONFIG_CFLAGS += -DHAVE_SETPROCTITLE
$(info autoconfig: using setproctitle)
@@ -3140,7 +3140,7 @@ endif
ifndef $(HAVE_WCSLCAT)
WCSFUNC=wcslcat
export WCSFUNC
-HAVE_WCSLCAT = $(shell $(MAKE) $(MAKE_OPTS) WCSFUNC=wcslcat have_wcsfunc)
+#HAVE_WCSLCAT = $(shell $(MAKE) $(MAKE_OPTS) WCSFUNC=wcslcat have_wcsfunc)
ifeq ($(HAVE_WCSLCAT),1)
CONFIG_CFLAGS += -DHAVE_WCSLCAT
$(info autoconfig: using wcslcat)
@@ -3150,7 +3150,7 @@ endif
ifndef $(HAVE_WCSLCPY)
WCSFUNC=wcslcpy
export WCSFUNC
-HAVE_WCSLCPY = $(shell $(MAKE) $(MAKE_OPTS) WCSFUNC=wcslcpy have_wcsfunc)
+#HAVE_WCSLCPY = $(shell $(MAKE) $(MAKE_OPTS) WCSFUNC=wcslcpy have_wcsfunc)
ifeq ($(HAVE_WCSLCPY),1)
CONFIG_CFLAGS += -DHAVE_WCSLCPY
$(info autoconfig: using wcslcpy)