You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

15 lines
616 B

--- a/meson.build
+++ b/meson.build
@@ -2045,8 +2045,11 @@ endif
# proxy-libintl subproject.
# FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
# implementations. This could be extended if issues are found in some platforms.
+#
+# 007-openwrt-libintl.patch: with BUILD_NLS=y use libintl-full, else use libc
+#
libintl_deps = []
-if cc.has_function('ngettext', args : osx_ldflags)
+if get_option('nls').disabled() and cc.has_function('ngettext', args : osx_ldflags)
have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
else
# First just find the bare library.