You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

28 lines
1020 B

From 65209e4fbf30d09dda89aa4b1d831461506848d7 Mon Sep 17 00:00:00 2001
From: Rafael Zalamena <rzalamena@opensourcerouting.org>
Date: Tue, 8 Oct 2019 20:47:38 -0300
Subject: [PATCH] configure.ac: fix memory sanitizer test
We should test for `-fsanitize=memory` instead of `-fsanitize=thread`
when enabling memory sanitizer. While here, fix the error message.
Signed-off-by: Rafael Zalamena <rzalamena@opensourcerouting.org>
---
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index 88f1c4f627..730e2ae6f0 100755
--- a/configure.ac
+++ b/configure.ac
@@ -328,8 +328,8 @@ if test "$enable_thread_sanitizer" = "yes"; then
])
fi
if test "$enable_memory_sanitizer" = "yes"; then
- AC_C_FLAG([-fsanitize=thread -fPIE -pie], [
- AC_MSG_ERROR([$CC does not support Thread Sanitizer.])
+ AC_C_FLAG([-fsanitize=memory -fPIE -pie], [
+ AC_MSG_ERROR([$CC does not support Memory Sanitizer.])
], [
SAN_FLAGS="-fsanitize=memory -fPIE -pie"
])