You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

58 lines
1.7 KiB

diff --git a/usr/Makefile b/usr/Makefile
index 1fae7e7..b05b970 100644
--- a/usr/Makefile
+++ b/usr/Makefile
@@ -1,13 +1,13 @@
sbindir ?= $(PREFIX)/sbin
libdir ?= $(PREFIX)/lib/tgt
-ifneq ($(shell test -e /usr/include/linux/signalfd.h && echo 1),)
+#ifneq ($(shell test -e /usr/include/linux/signalfd.h && echo 1),)
CFLAGS += -DUSE_SIGNALFD
-endif
+#endif
-ifneq ($(shell test -e /usr/include/sys/timerfd.h && echo 1),)
+#ifneq ($(shell test -e /usr/include/sys/timerfd.h && echo 1),)
CFLAGS += -DUSE_TIMERFD
-endif
+#endif
TGTD_OBJS += $(addprefix iscsi/, conn.o param.o session.o \
iscsid.o target.o chap.o sha1.o md5.o transport.o iscsi_tcp.o \
@@ -25,8 +25,9 @@ ifneq ($(SD_NOTIFY),)
CFLAGS += -DUSE_SYSTEMD
endif
-ifneq ($(shell test -e /usr/include/sys/eventfd.h && test -e /usr/include/libaio.h && echo 1),)
-CFLAGS += -DUSE_EVENTFD
+#ifneq ($(shell test -e /usr/include/sys/eventfd.h && test -e $(STAGING_DIR)/usr/include/libaio.h && echo 1),)
+ifneq ((test -e $(STAGING_DIR)/usr/include/libaio.h && echo 1),)
+CFLAGS += -DUSE_EVENTFD -I$(STAGING_DIR)/usr/include/
TGTD_OBJS += bs_aio.o
LIBS += -laio
endif
@@ -55,7 +56,7 @@ ifneq ($(SD_NOTIFY),)
LIBS += -lsystemd
endif
-PROGRAMS += tgtd tgtadm tgtimg
+PROGRAMS += tgtd tgtadm
TGTD_OBJS += tgtd.o mgmt.o target.o scsi.o log.o driver.o util.o work.o \
concat_buf.o parser.o spc.o sbc.o mmc.o osd.o scc.o smc.o \
ssc.o libssc.o bs_rdwr.o bs_ssc.o \
@@ -82,14 +83,8 @@ tgtadm: $(TGTADM_OBJS)
-include $(TGTADM_DEP)
-TGTIMG_OBJS = tgtimg.o libssc.o libcrc32c.o
TGTIMG_DEP = $(TGTIMG_OBJS:.o=.d)
-tgtimg: $(TGTIMG_OBJS)
- $(CC) $^ -o $@
-
--include $(TGTIMG_DEP)
-
%.o: %.c
$(CC) -c $(CFLAGS) $*.c -o $*.o
@$(CC) -MM $(CFLAGS) -MF $*.d -MT $*.o $*.c