|
--- a/gio/meson.build
|
|
+++ b/gio/meson.build
|
|
@@ -874,20 +874,6 @@ endif
|
|
|
|
# Dependencies used by executables below
|
|
have_libelf = false
|
|
-libelf = dependency('libelf', version : '>= 0.8.12', required : false)
|
|
-if libelf.found()
|
|
- have_libelf = true
|
|
-else
|
|
- # This fallback is necessary on *BSD. elfutils isn't the only libelf
|
|
- # implementation, and *BSD usually includes their own libelf as a system
|
|
- # library which doesn't have a corresponding .pc file.
|
|
- libelf = cc.find_library('elf', required : false)
|
|
- have_libelf = libelf.found()
|
|
- have_libelf = have_libelf and cc.has_function('elf_begin', dependencies : libelf)
|
|
- have_libelf = have_libelf and cc.has_function('elf_getshdrstrndx', dependencies : libelf)
|
|
- have_libelf = have_libelf and cc.has_function('elf_getshdrnum', dependencies : libelf)
|
|
- have_libelf = have_libelf and cc.has_header('libelf.h')
|
|
-endif
|
|
|
|
if have_libelf
|
|
glib_conf.set('HAVE_LIBELF', 1)
|