|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -39,12 +39,6 @@ if (CMAKE_SYSTEM_NAME STREQUAL "Darwin")
|
|
target_compile_definitions(miniupnpc-private INTERFACE _DARWIN_C_SOURCE)
|
|
endif ()
|
|
|
|
-# Set compiler specific build flags
|
|
-if (CMAKE_COMPILER_IS_GNUCC AND NOT CMAKE_SYSTEM_NAME STREQUAL "AmigaOS")
|
|
- set(CMAKE_POSITION_INDEPENDENT_CODE ON)
|
|
- target_compile_options(miniupnpc-private INTERFACE -Wall)
|
|
-endif ()
|
|
-
|
|
# Suppress noise warnings
|
|
if (MSVC)
|
|
target_compile_definitions(miniupnpc-private INTERFACE _CRT_SECURE_NO_WARNINGS)
|