You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

24 lines
691 B

Description: set a static version string rather than discern it from git
--- a/meson.build
+++ b/meson.build
@@ -19,6 +19,7 @@ add_project_arguments(
conf = configuration_data()
conf.set_quoted('PACKAGE_NAME', meson.project_name())
+conf.set('VCS_TAG', meson.project_version())
conf.set('_GNU_SOURCE', 1, description : 'Enable GNU extensions on systems that have them.')
build_arping = get_option('BUILD_ARPING')
@@ -208,10 +209,10 @@ foreach h : [
endif
endforeach
-git_version_h = vcs_tag(
+git_version_h = configure_file(
input : 'git-version.h.meson',
output : 'git-version.h',
- fallback : meson.project_version()
+ configuration: conf
)
config_h = configure_file(