|
From: ktkachov <ktkachov@138bc75d-0d04-0410-961f-82ee72b054a4>
|
|
Date: Fri, 8 May 2015 08:25:47 +0000 (+0000)
|
|
Subject: [PATCH 2/13] musl libc config
|
|
X-Git-Url: https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff_plain;h=a9173ceabaf29c16f8ef226fbf98af373a4b2ceb
|
|
|
|
[PATCH 2/13] musl libc config
|
|
|
|
2015-05-08 Gregor Richards <gregor.richards@uwaterloo.ca>
|
|
Szabolcs Nagy <szabolcs.nagy@arm.com>
|
|
|
|
* config.gcc (LIBC_MUSL): New tm_defines macro.
|
|
* config/linux.h (OPTION_MUSL): Define.
|
|
(MUSL_DYNAMIC_LINKER, MUSL_DYNAMIC_LINKER32,)
|
|
(MUSL_DYNAMIC_LINKER64, MUSL_DYNAMIC_LINKERX32,)
|
|
(INCLUDE_DEFAULTS_MUSL_GPP, INCLUDE_DEFAULTS_MUSL_LOCAL,)
|
|
(INCLUDE_DEFAULTS_MUSL_PREFIX, INCLUDE_DEFAULTS_MUSL_CROSS,)
|
|
(INCLUDE_DEFAULTS_MUSL_TOOL, INCLUDE_DEFAULTS_MUSL_NATIVE): Define.
|
|
* config/linux.opt (mmusl): New option.
|
|
* doc/invoke.texi (GNU/Linux Options): Document -mmusl.
|
|
* configure.ac (gcc_cv_libc_provides_ssp): Add *-*-musl*.
|
|
(gcc_cv_target_dl_iterate_phdr): Add *-linux-musl*.
|
|
* configure: Regenerate.
|
|
|
|
|
|
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@222904 138bc75d-0d04-0410-961f-82ee72b054a4
|
|
---
|
|
|
|
--- a/gcc/config.gcc
|
|
+++ b/gcc/config.gcc
|
|
@@ -575,7 +575,7 @@ case ${target} in
|
|
esac
|
|
|
|
# Common C libraries.
|
|
-tm_defines="$tm_defines LIBC_GLIBC=1 LIBC_UCLIBC=2 LIBC_BIONIC=3"
|
|
+tm_defines="$tm_defines LIBC_GLIBC=1 LIBC_UCLIBC=2 LIBC_BIONIC=3 LIBC_MUSL=4"
|
|
|
|
# 32-bit x86 processors supported by --with-arch=. Each processor
|
|
# MUST be separated by exactly one space.
|
|
@@ -720,6 +720,9 @@ case ${target} in
|
|
*-*-*uclibc*)
|
|
tm_defines="$tm_defines DEFAULT_LIBC=LIBC_UCLIBC"
|
|
;;
|
|
+ *-*-*musl*)
|
|
+ tm_defines="$tm_defines DEFAULT_LIBC=LIBC_MUSL"
|
|
+ ;;
|
|
*)
|
|
tm_defines="$tm_defines DEFAULT_LIBC=LIBC_GLIBC"
|
|
;;
|
|
--- a/gcc/config/linux.h
|
|
+++ b/gcc/config/linux.h
|
|
@@ -32,10 +32,12 @@ see the files COPYING3 and COPYING.RUNTI
|
|
#define OPTION_GLIBC (DEFAULT_LIBC == LIBC_GLIBC)
|
|
#define OPTION_UCLIBC (DEFAULT_LIBC == LIBC_UCLIBC)
|
|
#define OPTION_BIONIC (DEFAULT_LIBC == LIBC_BIONIC)
|
|
+#define OPTION_MUSL (DEFAULT_LIBC == LIBC_MUSL)
|
|
#else
|
|
#define OPTION_GLIBC (linux_libc == LIBC_GLIBC)
|
|
#define OPTION_UCLIBC (linux_libc == LIBC_UCLIBC)
|
|
#define OPTION_BIONIC (linux_libc == LIBC_BIONIC)
|
|
+#define OPTION_MUSL (linux_libc == LIBC_MUSL)
|
|
#endif
|
|
|
|
#define GNU_USER_TARGET_OS_CPP_BUILTINS() \
|
|
@@ -50,21 +52,25 @@ see the files COPYING3 and COPYING.RUNTI
|
|
} while (0)
|
|
|
|
/* Determine which dynamic linker to use depending on whether GLIBC or
|
|
- uClibc or Bionic is the default C library and whether
|
|
- -muclibc or -mglibc or -mbionic has been passed to change the default. */
|
|
+ uClibc or Bionic or musl is the default C library and whether
|
|
+ -muclibc or -mglibc or -mbionic or -mmusl has been passed to change
|
|
+ the default. */
|
|
|
|
-#define CHOOSE_DYNAMIC_LINKER1(LIBC1, LIBC2, LIBC3, LD1, LD2, LD3) \
|
|
- "%{" LIBC2 ":" LD2 ";:%{" LIBC3 ":" LD3 ";:" LD1 "}}"
|
|
+#define CHOOSE_DYNAMIC_LINKER1(LIBC1, LIBC2, LIBC3, LIBC4, LD1, LD2, LD3, LD4) \
|
|
+ "%{" LIBC2 ":" LD2 ";:%{" LIBC3 ":" LD3 ";:%{" LIBC4 ":" LD4 ";:" LD1 "}}}"
|
|
|
|
#if DEFAULT_LIBC == LIBC_GLIBC
|
|
-#define CHOOSE_DYNAMIC_LINKER(G, U, B) \
|
|
- CHOOSE_DYNAMIC_LINKER1 ("mglibc", "muclibc", "mbionic", G, U, B)
|
|
+#define CHOOSE_DYNAMIC_LINKER(G, U, B, M) \
|
|
+ CHOOSE_DYNAMIC_LINKER1 ("mglibc", "muclibc", "mbionic", "mmusl", G, U, B, M)
|
|
#elif DEFAULT_LIBC == LIBC_UCLIBC
|
|
-#define CHOOSE_DYNAMIC_LINKER(G, U, B) \
|
|
- CHOOSE_DYNAMIC_LINKER1 ("muclibc", "mglibc", "mbionic", U, G, B)
|
|
+#define CHOOSE_DYNAMIC_LINKER(G, U, B, M) \
|
|
+ CHOOSE_DYNAMIC_LINKER1 ("muclibc", "mglibc", "mbionic", "mmusl", U, G, B, M)
|
|
#elif DEFAULT_LIBC == LIBC_BIONIC
|
|
-#define CHOOSE_DYNAMIC_LINKER(G, U, B) \
|
|
- CHOOSE_DYNAMIC_LINKER1 ("mbionic", "mglibc", "muclibc", B, G, U)
|
|
+#define CHOOSE_DYNAMIC_LINKER(G, U, B, M) \
|
|
+ CHOOSE_DYNAMIC_LINKER1 ("mbionic", "mglibc", "muclibc", "mmusl", B, G, U, M)
|
|
+#elif DEFAULT_LIBC == LIBC_MUSL
|
|
+#define CHOOSE_DYNAMIC_LINKER(G, U, B, M) \
|
|
+ CHOOSE_DYNAMIC_LINKER1 ("mmusl", "mglibc", "muclibc", "mbionic", M, G, U, B)
|
|
#else
|
|
#error "Unsupported DEFAULT_LIBC"
|
|
#endif /* DEFAULT_LIBC */
|
|
@@ -81,24 +87,100 @@ see the files COPYING3 and COPYING.RUNTI
|
|
#define BIONIC_DYNAMIC_LINKER32 "/system/bin/linker"
|
|
#define BIONIC_DYNAMIC_LINKER64 "/system/bin/linker64"
|
|
#define BIONIC_DYNAMIC_LINKERX32 "/system/bin/linkerx32"
|
|
+/* Should be redefined for each target that supports musl. */
|
|
+#define MUSL_DYNAMIC_LINKER "/dev/null"
|
|
+#define MUSL_DYNAMIC_LINKER32 "/dev/null"
|
|
+#define MUSL_DYNAMIC_LINKER64 "/dev/null"
|
|
+#define MUSL_DYNAMIC_LINKERX32 "/dev/null"
|
|
|
|
#define GNU_USER_DYNAMIC_LINKER \
|
|
CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER, UCLIBC_DYNAMIC_LINKER, \
|
|
- BIONIC_DYNAMIC_LINKER)
|
|
+ BIONIC_DYNAMIC_LINKER, MUSL_DYNAMIC_LINKER)
|
|
#define GNU_USER_DYNAMIC_LINKER32 \
|
|
CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER32, UCLIBC_DYNAMIC_LINKER32, \
|
|
- BIONIC_DYNAMIC_LINKER32)
|
|
+ BIONIC_DYNAMIC_LINKER32, MUSL_DYNAMIC_LINKER32)
|
|
#define GNU_USER_DYNAMIC_LINKER64 \
|
|
CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER64, UCLIBC_DYNAMIC_LINKER64, \
|
|
- BIONIC_DYNAMIC_LINKER64)
|
|
+ BIONIC_DYNAMIC_LINKER64, MUSL_DYNAMIC_LINKER64)
|
|
#define GNU_USER_DYNAMIC_LINKERX32 \
|
|
CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKERX32, UCLIBC_DYNAMIC_LINKERX32, \
|
|
- BIONIC_DYNAMIC_LINKERX32)
|
|
+ BIONIC_DYNAMIC_LINKERX32, MUSL_DYNAMIC_LINKERX32)
|
|
|
|
/* Whether we have Bionic libc runtime */
|
|
#undef TARGET_HAS_BIONIC
|
|
#define TARGET_HAS_BIONIC (OPTION_BIONIC)
|
|
|
|
+/* musl avoids problematic includes by rearranging the include directories.
|
|
+ * Unfortunately, this is mostly duplicated from cppdefault.c */
|
|
+#if DEFAULT_LIBC == LIBC_MUSL
|
|
+#define INCLUDE_DEFAULTS_MUSL_GPP \
|
|
+ { GPLUSPLUS_INCLUDE_DIR, "G++", 1, 1, \
|
|
+ GPLUSPLUS_INCLUDE_DIR_ADD_SYSROOT, 0 }, \
|
|
+ { GPLUSPLUS_TOOL_INCLUDE_DIR, "G++", 1, 1, \
|
|
+ GPLUSPLUS_INCLUDE_DIR_ADD_SYSROOT, 1 }, \
|
|
+ { GPLUSPLUS_BACKWARD_INCLUDE_DIR, "G++", 1, 1, \
|
|
+ GPLUSPLUS_INCLUDE_DIR_ADD_SYSROOT, 0 },
|
|
+
|
|
+#ifdef LOCAL_INCLUDE_DIR
|
|
+#define INCLUDE_DEFAULTS_MUSL_LOCAL \
|
|
+ { LOCAL_INCLUDE_DIR, 0, 0, 1, 1, 2 }, \
|
|
+ { LOCAL_INCLUDE_DIR, 0, 0, 1, 1, 0 },
|
|
+#else
|
|
+#define INCLUDE_DEFAULTS_MUSL_LOCAL
|
|
+#endif
|
|
+
|
|
+#ifdef PREFIX_INCLUDE_DIR
|
|
+#define INCLUDE_DEFAULTS_MUSL_PREFIX \
|
|
+ { PREFIX_INCLUDE_DIR, 0, 0, 1, 0, 0},
|
|
+#else
|
|
+#define INCLUDE_DEFAULTS_MUSL_PREFIX
|
|
+#endif
|
|
+
|
|
+#ifdef CROSS_INCLUDE_DIR
|
|
+#define INCLUDE_DEFAULTS_MUSL_CROSS \
|
|
+ { CROSS_INCLUDE_DIR, "GCC", 0, 0, 0, 0},
|
|
+#else
|
|
+#define INCLUDE_DEFAULTS_MUSL_CROSS
|
|
+#endif
|
|
+
|
|
+#ifdef TOOL_INCLUDE_DIR
|
|
+#define INCLUDE_DEFAULTS_MUSL_TOOL \
|
|
+ { TOOL_INCLUDE_DIR, "BINUTILS", 0, 1, 0, 0},
|
|
+#else
|
|
+#define INCLUDE_DEFAULTS_MUSL_TOOL
|
|
+#endif
|
|
+
|
|
+#ifdef NATIVE_SYSTEM_HEADER_DIR
|
|
+#define INCLUDE_DEFAULTS_MUSL_NATIVE \
|
|
+ { NATIVE_SYSTEM_HEADER_DIR, 0, 0, 0, 1, 2 }, \
|
|
+ { NATIVE_SYSTEM_HEADER_DIR, 0, 0, 0, 1, 0 },
|
|
+#else
|
|
+#define INCLUDE_DEFAULTS_MUSL_NATIVE
|
|
+#endif
|
|
+
|
|
+#if defined (CROSS_DIRECTORY_STRUCTURE) && !defined (TARGET_SYSTEM_ROOT)
|
|
+# undef INCLUDE_DEFAULTS_MUSL_LOCAL
|
|
+# define INCLUDE_DEFAULTS_MUSL_LOCAL
|
|
+# undef INCLUDE_DEFAULTS_MUSL_NATIVE
|
|
+# define INCLUDE_DEFAULTS_MUSL_NATIVE
|
|
+#else
|
|
+# undef INCLUDE_DEFAULTS_MUSL_CROSS
|
|
+# define INCLUDE_DEFAULTS_MUSL_CROSS
|
|
+#endif
|
|
+
|
|
+#undef INCLUDE_DEFAULTS
|
|
+#define INCLUDE_DEFAULTS \
|
|
+ { \
|
|
+ INCLUDE_DEFAULTS_MUSL_GPP \
|
|
+ INCLUDE_DEFAULTS_MUSL_PREFIX \
|
|
+ INCLUDE_DEFAULTS_MUSL_CROSS \
|
|
+ INCLUDE_DEFAULTS_MUSL_TOOL \
|
|
+ INCLUDE_DEFAULTS_MUSL_NATIVE \
|
|
+ { GCC_INCLUDE_DIR, "GCC", 0, 1, 0, 0 }, \
|
|
+ { 0, 0, 0, 0, 0, 0 } \
|
|
+ }
|
|
+#endif
|
|
+
|
|
#if (DEFAULT_LIBC == LIBC_UCLIBC) && defined (SINGLE_LIBC) /* uClinux */
|
|
/* This is a *uclinux* target. We don't define below macros to normal linux
|
|
versions, because doing so would require *uclinux* targets to include
|
|
--- a/gcc/config/linux.opt
|
|
+++ b/gcc/config/linux.opt
|
|
@@ -28,5 +28,9 @@ Target Report RejectNegative Var(linux_l
|
|
Use GNU C library
|
|
|
|
muclibc
|
|
-Target Report RejectNegative Var(linux_libc,LIBC_UCLIBC) Negative(mbionic)
|
|
+Target Report RejectNegative Var(linux_libc,LIBC_UCLIBC) Negative(mmusl)
|
|
Use uClibc C library
|
|
+
|
|
+mmusl
|
|
+Target Report RejectNegative Var(linux_libc,LIBC_MUSL) Negative(mbionic)
|
|
+Use musl C library
|
|
--- a/gcc/configure
|
|
+++ b/gcc/configure
|
|
@@ -27833,6 +27833,9 @@ if test "${gcc_cv_libc_provides_ssp+set}
|
|
else
|
|
gcc_cv_libc_provides_ssp=no
|
|
case "$target" in
|
|
+ *-*-musl*)
|
|
+ # All versions of musl provide stack protector
|
|
+ gcc_cv_libc_provides_ssp=yes;;
|
|
*-*-linux* | *-*-kfreebsd*-gnu | *-*-knetbsd*-gnu)
|
|
# glibc 2.4 and later provides __stack_chk_fail and
|
|
# either __stack_chk_guard, or TLS access to stack guard canary.
|
|
@@ -27865,6 +27868,7 @@ fi
|
|
# <http://gcc.gnu.org/ml/gcc/2008-10/msg00130.html>) and for now
|
|
# simply assert that glibc does provide this, which is true for all
|
|
# realistically usable GNU/Hurd configurations.
|
|
+ # All supported versions of musl provide it as well
|
|
gcc_cv_libc_provides_ssp=yes;;
|
|
*-*-darwin* | *-*-freebsd*)
|
|
ac_fn_c_check_func "$LINENO" "__stack_chk_fail" "ac_cv_func___stack_chk_fail"
|
|
@@ -27961,6 +27965,9 @@ case "$target" in
|
|
gcc_cv_target_dl_iterate_phdr=no
|
|
fi
|
|
;;
|
|
+ *-linux-musl*)
|
|
+ gcc_cv_target_dl_iterate_phdr=yes
|
|
+ ;;
|
|
esac
|
|
|
|
if test x$gcc_cv_target_dl_iterate_phdr = xyes; then
|
|
--- a/gcc/configure.ac
|
|
+++ b/gcc/configure.ac
|
|
@@ -5287,6 +5287,9 @@ AC_CACHE_CHECK(__stack_chk_fail in targe
|
|
gcc_cv_libc_provides_ssp,
|
|
[gcc_cv_libc_provides_ssp=no
|
|
case "$target" in
|
|
+ *-*-musl*)
|
|
+ # All versions of musl provide stack protector
|
|
+ gcc_cv_libc_provides_ssp=yes;;
|
|
*-*-linux* | *-*-kfreebsd*-gnu | *-*-knetbsd*-gnu)
|
|
# glibc 2.4 and later provides __stack_chk_fail and
|
|
# either __stack_chk_guard, or TLS access to stack guard canary.
|
|
@@ -5313,6 +5316,7 @@ AC_CACHE_CHECK(__stack_chk_fail in targe
|
|
# <http://gcc.gnu.org/ml/gcc/2008-10/msg00130.html>) and for now
|
|
# simply assert that glibc does provide this, which is true for all
|
|
# realistically usable GNU/Hurd configurations.
|
|
+ # All supported versions of musl provide it as well
|
|
gcc_cv_libc_provides_ssp=yes;;
|
|
*-*-darwin* | *-*-freebsd*)
|
|
AC_CHECK_FUNC(__stack_chk_fail,[gcc_cv_libc_provides_ssp=yes],
|
|
@@ -5386,6 +5390,9 @@ case "$target" in
|
|
gcc_cv_target_dl_iterate_phdr=no
|
|
fi
|
|
;;
|
|
+ *-linux-musl*)
|
|
+ gcc_cv_target_dl_iterate_phdr=yes
|
|
+ ;;
|
|
esac
|
|
GCC_TARGET_TEMPLATE([TARGET_DL_ITERATE_PHDR])
|
|
if test x$gcc_cv_target_dl_iterate_phdr = xyes; then
|
|
--- a/gcc/doc/invoke.texi
|
|
+++ b/gcc/doc/invoke.texi
|
|
@@ -667,7 +667,7 @@ Objective-C and Objective-C++ Dialects}.
|
|
-mcpu=@var{cpu}}
|
|
|
|
@emph{GNU/Linux Options}
|
|
-@gccoptlist{-mglibc -muclibc -mbionic -mandroid @gol
|
|
+@gccoptlist{-mglibc -muclibc -mmusl -mbionic -mandroid @gol
|
|
-tno-android-cc -tno-android-ld}
|
|
|
|
@emph{H8/300 Options}
|
|
@@ -15340,13 +15340,19 @@ These @samp{-m} options are defined for
|
|
@item -mglibc
|
|
@opindex mglibc
|
|
Use the GNU C library. This is the default except
|
|
-on @samp{*-*-linux-*uclibc*} and @samp{*-*-linux-*android*} targets.
|
|
+on @samp{*-*-linux-*uclibc*}, @samp{*-*-linux-*musl*} and
|
|
+@samp{*-*-linux-*android*} targets.
|
|
|
|
@item -muclibc
|
|
@opindex muclibc
|
|
Use uClibc C library. This is the default on
|
|
@samp{*-*-linux-*uclibc*} targets.
|
|
|
|
+@item -mmusl
|
|
+@opindex mmusl
|
|
+Use the musl C library. This is the default on
|
|
+@samp{*-*-linux-*musl*} targets.
|
|
+
|
|
@item -mbionic
|
|
@opindex mbionic
|
|
Use Bionic C library. This is the default on
|