You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

23 lines
608 B

--- a/nspr/config/config.mk
+++ b/nspr/config/config.mk
@@ -126,6 +126,9 @@ endif
ifeq ($(USE_IPV6),1)
DEFINES += -D_PR_INET6
+ifeq ($(MUSL),1)
+CFLAGS += -D_PR_POLL_AVAILABLE -D_PR_HAVE_OFF64_T -D_PR_INET6 -D_PR_HAVE_INET_NTOP -D_PR_HAVE_GETHOSTBYNAME2 -D_PR_HAVE_GETADDRINFO -D_PR_INET6_PROBE
+endif
endif
ifeq ($(MOZ_UNICODE),1)
--- a/nspr/config/Makefile.in
+++ b/nspr/config/Makefile.in
@@ -30,7 +30,7 @@ CSRCS = now.c
# This version hasn't been ported for us; the one in mozilla/config has
ifneq ($(OS_ARCH),OS2)
-CSRCS += nsinstall.c
+#CSRCS += nsinstall.c
PLSRCS = nfspwd.pl
endif