--- a/nss/coreconf/arch.mk 2019-04-01 22:20:32.470080052 +0300
|
|
+++ b/nss/coreconf/arch.mk 2019-04-01 22:21:01.730987548 +0300
|
|
@@ -20,13 +20,13 @@
|
|
# Macros for getting the OS architecture
|
|
#
|
|
|
|
-OS_ARCH := $(subst /,_,$(shell uname -s))
|
|
+OS_ARCH ?= $(subst /,_,$(shell uname -s))
|
|
|
|
#
|
|
# Attempt to differentiate between sparc and x86 Solaris
|
|
#
|
|
|
|
-OS_TEST := $(shell uname -m)
|
|
+OS_TEST ?= $(shell uname -m)
|
|
ifeq ($(OS_TEST),i86pc)
|
|
OS_RELEASE := $(shell uname -r)_$(OS_TEST)
|
|
else
|