You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

15 lines
537 B

--- a/configure.ac
+++ b/configure.ac
@@ -26,7 +26,11 @@ VIPS_MAJOR_VERSION=vips_major_version()
VIPS_MINOR_VERSION=vips_minor_version()
VIPS_MICRO_VERSION=vips_micro_version()
VIPS_VERSION=vips_version()
-VIPS_VERSION_STRING="$VIPS_VERSION-$(date -u -r $srcdir/ChangeLog)"
+if test "x$SOURCE_DATE_EPOCH" = "x"; then
+ VIPS_VERSION_STRING=$VIPS_VERSION-`date -u -r ChangeLog`
+else
+ VIPS_VERSION_STRING=$VIPS_VERSION-`LC_ALL=C date --utc --date="@$SOURCE_DATE_EPOCH"`
+fi
# packages add to these as we find them
VIPS_CFLAGS=""