You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

37 lines
1.3 KiB

--- a/src/twisted/python/_setup.py
+++ b/src/twisted/python/_setup.py
@@ -169,11 +169,6 @@ class ConditionalExtension(Extension, object):
# The C extensions used for Twisted.
_EXTENSIONS = [
- ConditionalExtension(
- "twisted.test.raiser",
- sources=["src/twisted/test/raiser.c"],
- condition=lambda _: _isCPython),
-
ConditionalExtension(
"twisted.internet.iocpreactor.iocpsupport",
sources=[
@@ -238,12 +233,11 @@ def getSetupArgs(extensions=_EXTENSIONS):
"incremental >= 16.10.1",
"Automat >= 0.3.0",
"hyperlink >= 17.1.1",
- "PyHamcrest >= 1.9.0",
"attrs >= 17.4.0",
]
arguments.update(dict(
- packages=find_packages("src"),
+ packages=find_packages("src", exclude=["*.test", "*.test.*"]),
use_incremental=True,
setup_requires=["incremental >= 16.10.1"],
install_requires=requirements,
@@ -253,7 +247,7 @@ def getSetupArgs(extensions=_EXTENSIONS):
cmdclass=command_classes,
include_package_data=True,
exclude_package_data={
- "": ["*.c", "*.h", "*.pxi", "*.pyx", "build.bat"],
+ "": ["*.c", "*.h", "*.pxi", "*.pyx", "build.bat", "test/*"],
},
zip_safe=False,
extras_require=_EXTRAS_REQUIRE,