You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

27 lines
1015 B

--- a/testing/Makefile
+++ b/testing/Makefile
@@ -1,19 +1,19 @@
all: randchars randprintable test_speed-kernel test_speed-userspace match_kernel
randchars: randchars.c
- gcc -O2 -o randchars randchars.c
+ $(CC) $(CFLAGS) -o randchars randchars.c
randprintable: randprintable.c
- gcc -O2 -o randprintable randprintable.c
+ $(CC) $(CFLAGS) -o randprintable randprintable.c
test_speed-kernel: test_speed-kernel.c
- gcc -o test_speed-kernel test_speed-kernel.c
+ $(CC) $(CFLAGS) -o test_speed-kernel test_speed-kernel.c
test_speed-userspace: test_speed-userspace.cpp l7-parse-patterns.cpp l7-parse-patterns.h
- g++ -Wall -o test_speed-userspace test_speed-userspace.cpp l7-parse-patterns.cpp
+ $(CXX) $(CXXFLAGS) -Wall -o test_speed-userspace test_speed-userspace.cpp l7-parse-patterns.cpp
match_kernel: match-kernel.c
- gcc -O2 -o match_kernel match-kernel.c
+ $(CC) $(CFLAGS) -o match_kernel match-kernel.c
clean:
rm -f randprintable randchars test_speed-kernel test_speed-userspace match_kernel