Browse Source

Merge pull request #13227 from neheb/slhh

sslh: update to 1.21c
lilik-openwrt-22.03
Rosen Penev 4 years ago
committed by GitHub
parent
commit
fff511badf
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
4 changed files with 8 additions and 19 deletions
  1. +3
    -3
      net/sslh/Makefile
  2. +4
    -4
      net/sslh/patches/001-no_sslh_select.patch
  3. +1
    -1
      net/sslh/patches/002-configfile-fix.patch
  4. +0
    -11
      net/sslh/patches/010-format.patch

+ 3
- 3
net/sslh/Makefile View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sslh
PKG_VERSION:=v1.20
PKG_RELEASE:=3
PKG_VERSION:=v1.21c
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://rutschle.net/tech/sslh/
PKG_HASH:=a7f49b0a1cfcb7bb9d97f5ffa932bff11c5f65d9a9bd8fe1812481dee5855116
PKG_HASH:=3bfe783726f82c1f5a4be630ddc494ebb08dbb69980662cd7ffdeb7bc9e1e706
PKG_MAINTAINER:=Jonathan McCrohan <jmccrohan@gmail.com>
PKG_LICENSE:=GPL-2.0-or-later


+ 4
- 4
net/sslh/patches/001-no_sslh_select.patch View File

@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
@@ -68,7 +68,7 @@ all: sslh $(MAN) echosrv $(CONDITIONAL_T
@@ -76,7 +76,7 @@ all: sslh $(MAN) echosrv $(CONDITIONAL_TARGETS)
version.h:
./genver.sh >version.h
@ -9,7 +9,7 @@
$(OBJS): version.h
@@ -76,10 +76,6 @@ sslh-fork: version.h $(OBJS) sslh-fork.o
@@ -87,10 +87,6 @@ sslh-fork: version.h $(OBJS) sslh-fork.o Makefile common.h
$(CC) $(CFLAGS) $(LDFLAGS) -o sslh-fork sslh-fork.o $(OBJS) $(LIBS)
#strip sslh-fork
@ -20,8 +20,8 @@
systemd-sslh-generator: systemd-sslh-generator.o
$(CC) $(CFLAGS) $(LDFLAGS) -o systemd-sslh-generator systemd-sslh-generator.o -lconfig
@@ -115,7 +111,7 @@ distclean: clean
rm -f tags cscope.*
@@ -127,7 +123,7 @@ distclean: clean
rm -f tags sslh-conf.c sslh-conf.h cscope.*
clean:
- rm -f sslh-fork sslh-select echosrv version.h $(MAN) systemd-sslh-generator *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info


+ 1
- 1
net/sslh/patches/002-configfile-fix.patch View File

@ -25,6 +25,6 @@
- { name: "http"; host: "localhost"; port: "80"; },
+# { name: "xmpp"; host: "localhost"; port: "5222"; },
+# { name: "http"; host: "localhost"; port: "80"; },
{ name: "ssl"; host: "localhost"; port: "443"; log_level: 0; },
{ name: "tls"; host: "localhost"; port: "443"; log_level: 0; },
{ name: "anyprot"; host: "localhost"; port: "443"; }
);

+ 0
- 11
net/sslh/patches/010-format.patch View File

@ -1,11 +0,0 @@
--- a/sslh-main.c
+++ b/sslh-main.c
@@ -167,7 +167,7 @@ void cmd_ssl_to_tls(int argc, char* argv[])
strcpy(argv[i], "--tls");
/* foreground option not parsed yet, syslog not open, just print on
* stderr and hope for the best */
- fprintf(stderr, ssl_err_msg);
+ fprintf(stderr, "%s", ssl_err_msg);
}
}
}

Loading…
Cancel
Save