|
@ -1,6 +1,7 @@ |
|
|
--- a/configure.in
|
|
|
|
|
|
+++ b/configure.in
|
|
|
|
|
|
@@ -453,7 +453,10 @@ PHP_CHECK_FUNC(gethostname, nsl)
|
|
|
|
|
|
|
|
|
diff -u --recursive php-5.6.6-vanilla/configure.in php-5.6.6/configure.in
|
|
|
|
|
|
--- php-5.6.6-vanilla/configure.in 2015-02-26 22:10:51.865487530 -0500
|
|
|
|
|
|
+++ php-5.6.6/configure.in 2015-02-26 22:29:59.043102135 -0500
|
|
|
|
|
|
@@ -453,7 +453,10 @@
|
|
|
PHP_CHECK_FUNC(gethostbyaddr, nsl) |
|
|
PHP_CHECK_FUNC(gethostbyaddr, nsl) |
|
|
PHP_CHECK_FUNC(yp_get_default_domain, nsl) |
|
|
PHP_CHECK_FUNC(yp_get_default_domain, nsl) |
|
|
|
|
|
|
|
@ -12,3 +13,50 @@ |
|
|
if test "$ac_cv_func_dlopen" = "yes"; then |
|
|
if test "$ac_cv_func_dlopen" = "yes"; then |
|
|
AC_DEFINE(HAVE_LIBDL, 1, [ ]) |
|
|
AC_DEFINE(HAVE_LIBDL, 1, [ ]) |
|
|
fi |
|
|
fi |
|
|
|
|
|
diff -u --recursive php-5.6.6-vanilla/ext/fileinfo/config.m4 php-5.6.6/ext/fileinfo/config.m4
|
|
|
|
|
|
--- php-5.6.6-vanilla/ext/fileinfo/config.m4 2015-02-26 22:10:51.639487135 -0500
|
|
|
|
|
|
+++ php-5.6.6/ext/fileinfo/config.m4 2015-02-26 22:22:47.645609128 -0500
|
|
|
|
|
|
@@ -46,6 +46,10 @@
|
|
|
|
|
|
AC_MSG_RESULT(no) |
|
|
|
|
|
AC_MSG_NOTICE(using libmagic strcasestr implementation) |
|
|
|
|
|
libmagic_sources="$libmagic_sources libmagic/strcasestr.c" |
|
|
|
|
|
+ ],[
|
|
|
|
|
|
+ dnl cross-compiling; assume not present
|
|
|
|
|
|
+ AC_MSG_NOTICE(using libmagic strcasestr implementation)
|
|
|
|
|
|
+ libmagic_sources="$libmagic_sources libmagic/strcasestr.c"
|
|
|
|
|
|
]) |
|
|
|
|
|
|
|
|
|
|
|
PHP_NEW_EXTENSION(fileinfo, fileinfo.c $libmagic_sources, $ext_shared,,-I@ext_srcdir@/libmagic) |
|
|
|
|
|
diff -u --recursive php-5.6.6-vanilla/ext/opcache/config.m4 php-5.6.6/ext/opcache/config.m4
|
|
|
|
|
|
--- php-5.6.6-vanilla/ext/opcache/config.m4 2015-02-26 22:10:51.790487399 -0500
|
|
|
|
|
|
+++ php-5.6.6/ext/opcache/config.m4 2015-02-26 22:34:19.240414394 -0500
|
|
|
|
|
|
@@ -341,7 +341,14 @@
|
|
|
|
|
|
flock_type=linux |
|
|
|
|
|
AC_DEFINE([HAVE_FLOCK_LINUX], [], [Struct flock is Linux-type]) |
|
|
|
|
|
AC_MSG_RESULT("yes") |
|
|
|
|
|
-], AC_MSG_RESULT("no") )
|
|
|
|
|
|
+], [
|
|
|
|
|
|
+ AC_MSG_RESULT("no")
|
|
|
|
|
|
+], [
|
|
|
|
|
|
+ dnl cross-compiling; assume Linux
|
|
|
|
|
|
+ flock_type=linux
|
|
|
|
|
|
+ AC_DEFINE([HAVE_FLOCK_LINUX], [], [Struct flock is Linux-type])
|
|
|
|
|
|
+ AC_MSG_RESULT("yes")
|
|
|
|
|
|
+])
|
|
|
|
|
|
|
|
|
|
|
|
AC_MSG_CHECKING("whether flock struct is BSD ordered") |
|
|
|
|
|
AC_TRY_RUN([ |
|
|
|
|
|
@@ -357,7 +364,12 @@
|
|
|
|
|
|
flock_type=bsd |
|
|
|
|
|
AC_DEFINE([HAVE_FLOCK_BSD], [], [Struct flock is BSD-type]) |
|
|
|
|
|
AC_MSG_RESULT("yes") |
|
|
|
|
|
-], AC_MSG_RESULT("no") )
|
|
|
|
|
|
+], [
|
|
|
|
|
|
+ AC_MSG_RESULT("no")
|
|
|
|
|
|
+], [
|
|
|
|
|
|
+ dnl cross-compiling; assume Linux
|
|
|
|
|
|
+ AC_MSG_RESULT("no")
|
|
|
|
|
|
+])
|
|
|
|
|
|
|
|
|
|
|
|
if test "$flock_type" == "unknown"; then |
|
|
|
|
|
AC_MSG_ERROR([Don't know how to define struct flock on this system[,] set --enable-opcache=no]) |