Browse Source

hdparm: fix compilation with musl

Signed-off-by: Richard Kunze <richard.kunze@web.de>
lilik-openwrt-22.03
Richard Kunze 10 years ago
parent
commit
feb67e6b07
2 changed files with 22 additions and 0 deletions
  1. +2
    -0
      utils/hdparm/Makefile
  2. +20
    -0
      utils/hdparm/patches/001-fix-includes.patch

+ 2
- 0
utils/hdparm/Makefile View File

@ -19,6 +19,8 @@ PKG_LICENSE:=BSD-Style Open Source License
include $(INCLUDE_DIR)/package.mk
TARGET_CFLAGS+=-D_GNU_SOURCE
define Package/hdparm
SECTION:=utils
CATEGORY:=Utilities


+ 20
- 0
utils/hdparm/patches/001-fix-includes.patch View File

@ -0,0 +1,20 @@
--- a/hdparm.h
+++ b/hdparm.h
@@ -2,6 +2,7 @@
//#undef __KERNEL_STRICT_NAMES
#include <linux/types.h>
+#include <sys/types.h>
#if !defined(__GNUC__) && !defined(__attribute__)
#define __attribute__(x)
--- a/sysfs.c
+++ b/sysfs.c
@@ -12,6 +12,7 @@
#include <stdio.h>
#include <fcntl.h>
#include <errno.h>
+#include <limits.h>
#include <dirent.h>
#include <sys/stat.h>
#include <linux/types.h>

Loading…
Cancel
Save