Browse Source

Merge pull request #8100 from yangfl/lighttpd

lighttpd: Fix mod_auth
lilik-openwrt-22.03
Hannu Nyman 5 years ago
committed by GitHub
parent
commit
fdc5c5be60
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 39 additions and 6 deletions
  1. +10
    -6
      net/lighttpd/Makefile
  2. +29
    -0
      net/lighttpd/patches/020-Disable-auto-loading-mod_authn_file.patch

+ 10
- 6
net/lighttpd/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lighttpd
PKG_VERSION:=1.4.49
PKG_RELEASE:=4
PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://download.lighttpd.net/lighttpd/releases-1.4.x
@ -180,6 +180,10 @@ define BuildPlugin
$(INSTALL_DIR) $$(1)/etc/lighttpd/conf.d
if [ -f $(PKG_BUILD_DIR)/doc/config/conf.d/$(1).conf ]; then \
$(CP) $(PKG_BUILD_DIR)/doc/config/conf.d/$(1).conf $$(1)/etc/lighttpd/conf.d/$(4)-$(1).conf ; \
if ! grep -qF 'mod_$(1)' $$(1)/etc/lighttpd/conf.d/$(4)-$(1).conf; then \
sed -i "`sed '/^##/ !q' $$(1)/etc/lighttpd/conf.d/$(4)-$(1).conf | wc -l` i\
server.modules += ( \"mod_$(1)\" )" $$(1)/etc/lighttpd/conf.d/$(4)-$(1).conf ; \
fi \
else \
echo 'server.modules += ( "mod_$(1)" )' > $$(1)/etc/lighttpd/conf.d/$(4)-$(1).conf ; \
fi
@ -195,11 +199,11 @@ $(eval $(call BuildPackage,lighttpd))
$(eval $(call BuildPlugin,redirect,URL redirection,+PACKAGE_lighttpd-mod-redirect:libpcre,10))
# Next, permit authentication.
$(eval $(call BuildPlugin,auth,Authentication,+lighttpd-mod-authn_file,20))
$(eval $(call BuildPlugin,authn_file,File-based authentication,+lighttpd-mod-auth,20))
$(eval $(call BuildPlugin,authn_gssapi,Kerberos-based authentication,+lighttpd-mod-auth +PACKAGE_lighttpd-mod-authn_gssapi:krb5-libs,20))
$(eval $(call BuildPlugin,authn_ldap,LDAP-based authentication,+lighttpd-mod-auth +PACKAGE_lighttpd-mod-authn_ldap:libopenldap,20))
$(eval $(call BuildPlugin,authn_mysql,Mysql-based authentication,+lighttpd-mod-auth +PACKAGE_lighttpd-mod-authn_mysql:libmysqlclient,20))
$(eval $(call BuildPlugin,auth,Authentication,,20))
$(eval $(call BuildPlugin,authn_file,File-based authentication,lighttpd-mod-auth,20))
$(eval $(call BuildPlugin,authn_gssapi,Kerberos-based authentication,lighttpd-mod-auth +PACKAGE_lighttpd-mod-authn_gssapi:krb5-libs,20))
$(eval $(call BuildPlugin,authn_ldap,LDAP-based authentication,lighttpd-mod-auth +PACKAGE_lighttpd-mod-authn_ldap:libopenldap,20))
$(eval $(call BuildPlugin,authn_mysql,Mysql-based authentication,lighttpd-mod-auth +PACKAGE_lighttpd-mod-authn_mysql:libmysqlclient,20))
# Finally, everything else.
$(eval $(call BuildPlugin,access,Access restrictions,,30))


+ 29
- 0
net/lighttpd/patches/020-Disable-auto-loading-mod_authn_file.patch View File

@ -0,0 +1,29 @@
From 72f2c7559a1cd75b6d86e72358b4b78cdeefa5f4 Mon Sep 17 00:00:00 2001
From: yangfl <yangfl@users.noreply.github.com>
Date: Fri, 1 Feb 2019 15:05:32 +0800
Subject: [PATCH] Disable auto loading mod_authn_file
Which will cause openwrt/packages#7737
---
src/configfile.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/configfile.c b/src/configfile.c
index 1b2651b9..29bb2aa4 100644
--- a/src/configfile.c
+++ b/src/configfile.c
@@ -482,9 +482,9 @@ static int config_insert(server *srv) {
* existing lighttpd 1.4.x configs */
if (contains_mod_auth) {
if (append_mod_authn_file) {
- ds = data_string_init();
+ /* ds = data_string_init();
buffer_copy_string_len(ds->value, CONST_STR_LEN("mod_authn_file"));
- array_insert_unique(srv->srvconf.modules, (data_unset *)ds);
+ array_insert_unique(srv->srvconf.modules, (data_unset *)ds); */
}
if (append_mod_authn_ldap) {
#if defined(HAVE_LDAP_H) && defined(HAVE_LBER_H) && defined(HAVE_LIBLDAP) && defined(HAVE_LIBLBER)
--
2.20.1

Loading…
Cancel
Save