Browse Source

libmariadb: fix compilation cmake issue

This patch fixes the compilation issue of the upstream Cmake file.
If this patch is not applied we get the following compilation error output.

CMake Error at cmake/ConnectorName.cmake:30 (ENDMACRO):
  Flow control statements are not properly nested.
Call Stack (most recent call first):
  CMakeLists.txt:423 (INCLUDE)

The blamed cmake/ConnectorName.cmake file gets fixed with this patch.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
lilik-openwrt-22.03
Florian Eckert 3 years ago
parent
commit
fd13c120e7
1 changed files with 11 additions and 0 deletions
  1. +11
    -0
      libs/libmariadb/patches/0001-libmariadb-fix-cmake.patch

+ 11
- 0
libs/libmariadb/patches/0001-libmariadb-fix-cmake.patch View File

@ -0,0 +1,11 @@
--- a/cmake/ConnectorName.cmake
+++ b/cmake/ConnectorName.cmake
@@ -22,7 +22,7 @@ IF(CMAKE_SYSTEM_NAME MATCHES "Windows")
SET(MACHINE_NAME "x64")
ELSE()
SET(MACHINE_NAME "32")
- END()
+ ENDIF()
ENDIF()
SET(product_name "mysql-connector-c-${CPACK_PACKAGE_VERSION}-${PLATFORM_NAME}${CONCAT_SIGN}${MACHINE_NAME}")

Loading…
Cancel
Save