Browse Source

i2pd: update to 2.36

remove AVX patches as upstream has integrated and closed
all AVX issues

compiled on :  x86-64, i386 generic
tested on : x86-64 VM, i386 VM

Signed-off-by: Dirk Neukirchen <plntyk.lede@plntyk.name>
lilik-openwrt-22.03
Dirk Neukirchen 3 years ago
parent
commit
fc7d710e62
2 changed files with 3 additions and 35 deletions
  1. +3
    -3
      net/i2pd/Makefile
  2. +0
    -32
      net/i2pd/patches/020-x86.patch

+ 3
- 3
net/i2pd/Makefile View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=i2pd
PKG_VERSION:=2.35.0
PKG_RELEASE:=3
PKG_VERSION:=2.36.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/PurpleI2P/i2pd/tar.gz/$(PKG_VERSION)?
PKG_HASH:=d041fd4e7a88ac168e76f66fdab40174ad093cdc13451cdbd0dd1216e5581f8a
PKG_HASH:=17b7309cbee41b991cf9480334495c5a049f709beb1b31fbfcb47de19c8462a3
PKG_MAINTAINER:=David Yang <mmyangfl@gmail.com>
PKG_LICENSE:=BSD-3-Clause


+ 0
- 32
net/i2pd/patches/020-x86.patch View File

@ -1,32 +0,0 @@
From ca3b8191510c1006d031d02c50edcf6b4f6a6e8f Mon Sep 17 00:00:00 2001
From: R4SAS <r4sas@i2pmail.org>
Date: Thu, 10 Dec 2020 18:32:41 +0300
Subject: [PATCH] [avx] check ig c++ target supports AVX
Signed-off-by: R4SAS <r4sas@i2pmail.org>
---
libi2pd/Crypto.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/libi2pd/Crypto.cpp
+++ b/libi2pd/Crypto.cpp
@@ -638,7 +638,7 @@ namespace crypto
{
uint64_t buf[256];
uint64_t hash[12]; // 96 bytes
-#if defined(__x86_64__) || defined(__i386__)
+#if (defined(__x86_64__) || defined(__i386__)) && defined(__AVX__) // not all X86 targets supports AVX (like old Pentium, see #1600)
if(i2p::cpu::avx)
{
__asm__
--- a/libi2pd/Identity.cpp
+++ b/libi2pd/Identity.cpp
@@ -828,7 +828,7 @@ namespace data
XORMetric operator^(const IdentHash& key1, const IdentHash& key2)
{
XORMetric m;
-#if defined(__x86_64__) || defined(__i386__)
+#if (defined(__x86_64__) || defined(__i386__)) && defined(__AVX__) // not all X86 targets supports AVX (like old Pentium, see #1600)
if(i2p::cpu::avx)
{
__asm__

Loading…
Cancel
Save