Browse Source

openvswitch: bump to version 2.8.2

Changes since 2.8.2 as recorded in NEWS-2.8.2

    - NSH implementation now conforms to latest draft (draft-ietf-sfc-nsh-28).
    - Bug fixes

0006-adapt-ovs-scripts.patch was splited into two separate patches as
the original patch does not apply against 2.8.2 anymore.  Other patches
are just re-numbered without actual function change

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
lilik-openwrt-22.03
Yousong Zhou 7 years ago
parent
commit
fa958f4a99
8 changed files with 83 additions and 49 deletions
  1. +3
    -3
      net/openvswitch/Makefile
  2. +0
    -0
      net/openvswitch/patches/0001-musl-compatibility.patch
  3. +0
    -30
      net/openvswitch/patches/0006-adapt-ovs-scripts.patch
  4. +5
    -5
      net/openvswitch/patches/0100-netdev-linux-Use-unsigned-int-for-ifi_flags.patch
  5. +6
    -6
      net/openvswitch/patches/0101-netdev-linux-Let-interface-flag-survive-internal-por.patch
  6. +5
    -5
      net/openvswitch/patches/0102-python-separate-host-target-python-for-cross-compile.patch
  7. +33
    -0
      net/openvswitch/patches/0103-ovs-ctl-fix-setting-hostname.patch
  8. +31
    -0
      net/openvswitch/patches/0104-ovs-lib-fix-install_dir.patch

+ 3
- 3
net/openvswitch/Makefile View File

@ -12,15 +12,15 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=openvswitch
PKG_VERSION:=2.8.1
PKG_RELEASE:=3
PKG_VERSION:=2.8.2
PKG_RELEASE:=1
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=COPYING
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.openvswitch.org/releases/
PKG_HASH:=8d1c439e26d7044f0ec823c7fef1b00b7c6465da0b83a7d0cf3191ed1dc43893
PKG_HASH:=87b4a7e7134a44ce1f808d3415a2244b4518c2b0b2a42fa2f8231e592f13103d
PKG_BUILD_DEPENDS:=python/host python-six/host


net/openvswitch/patches/0004-musl-compatibility.patch → net/openvswitch/patches/0001-musl-compatibility.patch View File


+ 0
- 30
net/openvswitch/patches/0006-adapt-ovs-scripts.patch View File

@ -1,30 +0,0 @@
diff --git a/utilities/ovs-ctl.in b/utilities/ovs-ctl.in
index dc1d02c..61ecf2f 100755
--- a/utilities/ovs-ctl.in
+++ b/utilities/ovs-ctl.in
@@ -108,7 +108,7 @@ set_system_ids () {
esac
set "$@" external-ids:system-id="\"$SYSTEM_ID\""
- set "$@" external-ids:hostname="\"$(hostname -f)\""
+ set "$@" external-ids:hostname="\"$(cat /proc/sys/kernel/hostname)\""
set "$@" external-ids:rundir="\"$rundir\""
diff --git a/utilities/ovs-lib.in b/utilities/ovs-lib.in
index 8665698..7931bc6 100644
--- a/utilities/ovs-lib.in
+++ b/utilities/ovs-lib.in
@@ -157,7 +157,11 @@ install_dir () {
[ "${OVS_USER##*:}" != "" ] && INSTALL_GROUP="${OVS_USER##*:}"
if test ! -d "$DIR"; then
- install -d -m "$INSTALL_MODE" -o "$INSTALL_USER" -g "$INSTALL_GROUP" "$DIR"
+ mkdir -p "$DIR"
+ [ -n "$INSTALL_MODE" ] && chmod "$INSTALL_MODE" "$DIR"
+ local OWN="$INSTALL_USER"
+ [ -n "$OWN" ] && [ -n "$INSTALL_GROUP" ] && OWN="${OWN}:${INSTALL_GROUP}"
+ [ -n "$OWN" ] && chown "$OWN" "$DIR"
restorecon "$DIR" >/dev/null 2>&1
fi
}

net/openvswitch/patches/0001-netdev-linux-Use-unsigned-int-for-ifi_flags.patch → net/openvswitch/patches/0100-netdev-linux-Use-unsigned-int-for-ifi_flags.patch View File


net/openvswitch/patches/0002-netdev-linux-Let-interface-flag-survive-internal-por.patch → net/openvswitch/patches/0101-netdev-linux-Let-interface-flag-survive-internal-por.patch View File


net/openvswitch/patches/0003-python-separate-host-target-python-for-cross-compile.patch → net/openvswitch/patches/0102-python-separate-host-target-python-for-cross-compile.patch View File


+ 33
- 0
net/openvswitch/patches/0103-ovs-ctl-fix-setting-hostname.patch View File

@ -0,0 +1,33 @@
From 05a6fa94778f9d6c54ca676de80708d03d6c365a Mon Sep 17 00:00:00 2001
From: Yousong Zhou <yszhou4tech@gmail.com>
Date: Wed, 14 Mar 2018 16:40:01 +0800
Subject: [PATCH 103/104] ovs-ctl: fix setting hostname
The command "hostname" is not available in OpenWrt by default.
The other thing to note is that currently kernel.hostname is not a fully
qualitied name
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
---
utilities/ovs-ctl.in | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/utilities/ovs-ctl.in b/utilities/ovs-ctl.in
index 4ddc450fb..52018e6d3 100755
--- a/utilities/ovs-ctl.in
+++ b/utilities/ovs-ctl.in
@@ -68,9 +68,7 @@ ovs_vsctl () {
}
set_hostname () {
- # 'hostname -f' needs network connectivity to work. So we should
- # call this only after ovs-vswitchd is running.
- ovs_vsctl set Open_vSwitch . external-ids:hostname="$(hostname -f)"
+ ovs_vsctl set Open_vSwitch . external-ids:hostname="$(sysctl -n kernel.hostname)"
}
set_system_ids () {
--
2.16.2

+ 31
- 0
net/openvswitch/patches/0104-ovs-lib-fix-install_dir.patch View File

@ -0,0 +1,31 @@
From d8dd661e1c100a2d2ba0361cf6c91dcdedfeeb70 Mon Sep 17 00:00:00 2001
From: Yousong Zhou <yszhou4tech@gmail.com>
Date: Wed, 14 Mar 2018 16:44:13 +0800
Subject: [PATCH 104/104] ovs-lib: fix install_dir()
The command "install" is not available in OpenWrt by default
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
---
utilities/ovs-lib.in | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/utilities/ovs-lib.in b/utilities/ovs-lib.in
index 1bccea0c5..457297f3f 100644
--- a/utilities/ovs-lib.in
+++ b/utilities/ovs-lib.in
@@ -157,7 +157,10 @@ install_dir () {
[ "${OVS_USER##*:}" != "" ] && INSTALL_GROUP="${OVS_USER##*:}"
if test ! -d "$DIR"; then
- install -d -m "$INSTALL_MODE" -o "$INSTALL_USER" -g "$INSTALL_GROUP" "$DIR"
+ mkdir -p "$DIR"
+ chmod "$INSTALL_MODE"
+ chown "$INSTALL_USER" "$DIR"
+ chgrp "$INSTALL_GROUP" "$DIR"
restorecon "$DIR" >/dev/null 2>&1
fi
}
--
2.16.2

Loading…
Cancel
Save