Browse Source

libdnet: update to 1.14

Clean up the Makefile to modern standards.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
f9d67865be
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 11 additions and 48 deletions
  1. +11
    -25
      libs/libdnet/Makefile
  2. +0
    -23
      libs/libdnet/patches/002-config.patch

+ 11
- 25
libs/libdnet/Makefile View File

@ -8,20 +8,20 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libdnet
PKG_VERSION:=1.12
PKG_VERSION:=1.14
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/dugsong/libdnet/archive
PKG_HASH:=b6360659c93fa2e3cde9e0a1fc9c07bc4111f3448c5de856e095eb98315dd424
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_SOURCE_URL:=https://codeload.github.com/ofalk/libdnet/tar.gz/$(PKG_NAME)-$(PKG_VERSION)?
PKG_HASH:=592599c54a57102a177270f3a2caabda2c2ac7768b977d7458feba97da923dfe
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_NAME)-$(PKG_VERSION)
PKG_LICENSE:=BSD
PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
@ -29,7 +29,7 @@ define Package/libdnet
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Low-level network library
URL:=http://sourceforge.net/projects/libdnet/
URL:=https://github.com/ofalk/libdnet
endef
define Package/libdnet/description
@ -37,19 +37,10 @@ define Package/libdnet/description
networking routines.
endef
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
--without-check \
--without-python
CONFIGURE_VARS += \
ac_cv_dnet_bsd_bpf=no
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE"
--without-python \
--without-wpdpack
define Build/InstallDev
$(INSTALL_DIR) $(2)/bin
@ -79,11 +70,6 @@ define Package/libdnet/install
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/libdnet.so.* \
$(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) \
$(PKG_INSTALL_DIR)/usr/sbin/dnet \
$(1)/usr/sbin/
endef
$(eval $(call BuildPackage,libdnet))

+ 0
- 23
libs/libdnet/patches/002-config.patch View File

@ -1,23 +0,0 @@
--- a/dnet-config.in
+++ b/dnet-config.in
@@ -45,10 +45,18 @@ while test $# -gt 0; do
done
if test "$echo_cflags" = "yes"; then
- echo -I@includedir@
+ includes=
+ if test "@includedir@" != "/usr/include" ; then
+ includes=-I@includedir@
+ fi
+ echo $includes
fi
if test "$echo_libs" = "yes"; then
- echo -L@libdir@ -ldnet @LIBS@
+ libs=
+ if test "@libdir@" != "/usr/lib" ; then
+ libs=-I@libdir@
+ fi
+ echo $libs -ldnet @LIBS@
fi

Loading…
Cancel
Save