Browse Source

spdlog: update to 1.9.2

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 3 years ago
parent
commit
f890882752
2 changed files with 2 additions and 13 deletions
  1. +2
    -2
      libs/spdlog/Makefile
  2. +0
    -11
      libs/spdlog/patches/010-fmt8.patch

+ 2
- 2
libs/spdlog/Makefile View File

@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=spdlog
PKG_VERSION:=1.8.5
PKG_VERSION:=1.9.2
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/gabime/spdlog/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=944d0bd7c763ac721398dca2bb0f3b5ed16f67cef36810ede5061f35a543b4b8
PKG_HASH:=6fff9215f5cb81760be4cc16d033526d1080427d236e86d70bb02994f85e3d38
PKG_MAINTAINER:=
PKG_LICENSE:=MIT


+ 0
- 11
libs/spdlog/patches/010-fmt8.patch View File

@ -1,11 +0,0 @@
--- a/include/spdlog/common-inl.h
+++ b/include/spdlog/common-inl.h
@@ -60,7 +60,7 @@ SPDLOG_INLINE spdlog_ex::spdlog_ex(std::
SPDLOG_INLINE spdlog_ex::spdlog_ex(const std::string &msg, int last_errno)
{
memory_buf_t outbuf;
- fmt::format_system_error(outbuf, last_errno, msg);
+ fmt::format_system_error(outbuf, last_errno, msg.data());
msg_ = fmt::to_string(outbuf);
}

Loading…
Cancel
Save