Browse Source

Merge pull request #3181 from MikePetullo/for-15.05-luasec

luasec: remove obsolete patches
lilik-openwrt-22.03
Hannu Nyman 8 years ago
committed by GitHub
parent
commit
f84a7cd453
2 changed files with 0 additions and 44 deletions
  1. +0
    -20
      lang/luasec/patches/100-luasocket-Makefile.patch
  2. +0
    -24
      lang/luasec/patches/200-compression-method-fix.patch

+ 0
- 20
lang/luasec/patches/100-luasocket-Makefile.patch View File

@ -1,20 +0,0 @@
--- luasec-luasec-0.5-old/src/luasocket/Makefile 2014-01-29 21:43:33.000000000 +0100
+++ luasec-luasec-0.5/src/luasocket/Makefile 2014-11-30 13:07:44.850051000 +0100
@@ -6,7 +6,7 @@
CC ?= cc
CFLAGS += $(MYCFLAGS) -DLUASOCKET_DEBUG
-AR := ar rcu
+AR ?= ar
RANLIB ?= ranlib
.PHONY: all clean
@@ -14,7 +14,7 @@
all: libluasocket.a
libluasocket.a: $(OBJS)
- $(AR) $@ $(OBJS)
+ $(AR) rcu $@ $(OBJS)
$(RANLIB) $@
clean:

+ 0
- 24
lang/luasec/patches/200-compression-method-fix.patch View File

@ -1,24 +0,0 @@
--- a/src/ssl.c
+++ b/src/ssl.c
@@ -401,17 +401,21 @@ static int meth_want(lua_State *L)
*/
static int meth_compression(lua_State *L)
{
+#ifndef OPENSSL_NO_COMP
const COMP_METHOD *comp;
+#endif
p_ssl ssl = (p_ssl)luaL_checkudata(L, 1, "SSL:Connection");
if (ssl->state != LSEC_STATE_CONNECTED) {
lua_pushnil(L);
lua_pushstring(L, "closed");
return 2;
}
+#ifndef OPENSSL_NO_COMP
comp = SSL_get_current_compression(ssl->ssl);
if (comp)
lua_pushstring(L, SSL_COMP_get_name(comp));
else
+#endif
lua_pushnil(L);
return 1;
}

Loading…
Cancel
Save