Browse Source

bash: Refresh patches

Signed-off-by: Marcel Denia <naoir@gmx.net>
lilik-openwrt-22.03
Marcel Denia 10 years ago
parent
commit
f73ee0d75d
3 changed files with 9 additions and 10 deletions
  1. +2
    -2
      utils/bash/patches/001-compile-fix.patch
  2. +4
    -4
      utils/bash/patches/002-force-internal-readline.patch
  3. +3
    -4
      utils/bash/patches/129-no_doc.patch

+ 2
- 2
utils/bash/patches/001-compile-fix.patch View File

@ -1,6 +1,6 @@
--- a/execute_cmd.c
+++ b/execute_cmd.c
@@ -2202,7 +2202,11 @@ execute_pipeline (command, asynchronous,
@@ -2369,7 +2369,11 @@ execute_pipeline (command, asynchronous,
/* If the `lastpipe' option is set with shopt, and job control is not
enabled, execute the last element of non-async pipelines in the
current shell environment. */
@ -11,5 +11,5 @@
+#endif
+ asynchronous == 0 && pipe_out == NO_PIPE && prev > 0)
{
lstdin = move_to_high_fd (0, 0, 255);
lstdin = move_to_high_fd (0, 1, -1);
if (lstdin > 0)

+ 4
- 4
utils/bash/patches/002-force-internal-readline.patch View File

@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
@@ -5748,8 +5748,7 @@ _ACEOF
@@ -5430,8 +5430,7 @@ if test $opt_readline = yes; then
# static version specified as -llibname to override the
# dynamic version
case "${host_os}" in
@ -10,9 +10,9 @@
esac
fi
else
--- a/configure.in
+++ b/configure.in
@@ -540,8 +540,7 @@ if test $opt_readline = yes; then
--- a/configure.ac
+++ b/configure.ac
@@ -578,8 +578,7 @@ if test $opt_readline = yes; then
# static version specified as -llibname to override the
# dynamic version
case "${host_os}" in


+ 3
- 4
utils/bash/patches/129-no_doc.patch View File

@ -1,7 +1,6 @@
diff -urN bash-4.2/Makefile.in bash-4.2.new/Makefile.in
--- bash-4.2/Makefile.in 2010-12-01 01:22:42.000000000 +0100
+++ bash-4.2.new/Makefile.in 2012-07-30 16:24:01.325057998 +0200
@@ -724,10 +724,8 @@
--- a/Makefile.in
+++ b/Makefile.in
@@ -741,10 +741,8 @@ reconfig: force
# $(MAKE) -f $(srcdir)/Makefile $(MFLAGS) srcdir=$(srcdir)
doc documentation: force


Loading…
Cancel
Save