Browse Source

Merge pull request #3818 from commodo/youtube-dl-fix

python: update package to fix youtube-dl build
lilik-openwrt-22.03
Hannu Nyman 8 years ago
committed by GitHub
parent
commit
f6e419799a
5 changed files with 7 additions and 71 deletions
  1. +7
    -5
      lang/python/Makefile
  2. +0
    -9
      lang/python/files/python-host.mk
  3. +0
    -31
      lang/python/patches/005-fix-libffi-x86-64-configure.patch
  4. +0
    -15
      lang/python/patches/011-do-not-prefer-ncursesw.patch
  5. +0
    -11
      lang/python/patches/012-disable-openssl-for-hashlib-on-host-build.patch

+ 7
- 5
lang/python/Makefile View File

@ -12,7 +12,7 @@ include ./files/python-version.mk
PKG_NAME:=python
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
@ -36,7 +36,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/Python-$(PKG_VERSION)
PKG_BUILD_DEPENDS:=python/host
HOST_BUILD_DEPENDS:=bzip2/host expat/host libffi/host
HOST_BUILD_DEPENDS:=bzip2/host expat/host
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
@ -229,6 +229,9 @@ define PyPackage/python/filespec
-|$(PYTHON_PKG_DIR)
endef
HOST_LDFLAGS += \
$$$$(pkg-config --static --libs libcrypto libssl)
HOST_CONFIGURE_ARGS+= \
--without-cxx-main \
--without-pymalloc \
@ -236,9 +239,8 @@ HOST_CONFIGURE_ARGS+= \
--prefix=$(HOST_PYTHON_DIR) \
--exec-prefix=$(HOST_PYTHON_DIR) \
--with-system-expat=$(STAGING_DIR_HOSTPKG) \
--with-system-ffi \
CONFIG_SITE= \
CFLAGS="$(HOST_CFLAGS)"
--with-system-ffi=no \
CONFIG_SITE=
define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) install


+ 0
- 9
lang/python/files/python-host.mk View File

@ -84,13 +84,4 @@ define HostPy/Compile/Default
)
endef
ifeq ($(BUILD_VARIANT),python)
define Host/Compile
$(call HostPy/Compile/Default)
endef
define Host/Install
endef
endif # python
endif # __python_host_mk_inc

+ 0
- 31
lang/python/patches/005-fix-libffi-x86-64-configure.patch View File

@ -1,31 +0,0 @@
diff --git a/Modules/_ctypes/libffi/configure b/Modules/_ctypes/libffi/configure
index 75f62a7..4d6c9f2 100755
--- a/Modules/_ctypes/libffi/configure
+++ b/Modules/_ctypes/libffi/configure
@@ -17257,20 +17257,12 @@ case "$host" in
fi
;;
- i?86-*-* | x86_64-*-*)
- TARGETDIR=x86
- if test $ac_cv_sizeof_size_t = 4; then
- case "$host" in
- *-gnux32)
- TARGET=X86_64
- ;;
- *)
- TARGET=X86
- ;;
- esac
- else
- TARGET=X86_64;
- fi
+ i?86-*-*)
+ TARGET=X86; TARGETDIR=x86
+ ;;
+
+ x86_64-*-*)
+ TARGET=X86_64; TARGETDIR=x86
;;
ia64*-*-*)

+ 0
- 15
lang/python/patches/011-do-not-prefer-ncursesw.patch View File

@ -1,15 +0,0 @@
diff --git a/setup.py b/setup.py
index 7868b7b..86b0119 100644
--- a/setup.py
+++ b/setup.py
@@ -725,8 +725,8 @@ class PyBuildExt(build_ext):
# use the same library for the readline and curses modules.
if 'curses' in readline_termcap_library:
curses_library = readline_termcap_library
- elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
- curses_library = 'ncursesw'
+ #elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
+ # curses_library = 'ncursesw'
elif self.compiler.find_library_file(lib_dirs, 'ncurses'):
curses_library = 'ncurses'
elif self.compiler.find_library_file(lib_dirs, 'curses'):

+ 0
- 11
lang/python/patches/012-disable-openssl-for-hashlib-on-host-build.patch View File

@ -1,11 +0,0 @@
--- a/setup.py
+++ b/setup.py
@@ -859,7 +859,7 @@ class PyBuildExt(build_ext):
min_openssl_ver = 0x00907000
have_any_openssl = ssl_incs is not None and ssl_libs is not None
- have_usable_openssl = (have_any_openssl and
+ have_usable_openssl = cross_compiling and (have_any_openssl and
openssl_ver >= min_openssl_ver)
if have_any_openssl:

Loading…
Cancel
Save