Browse Source

libftdi: fix cmake build issues

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
lilik-openwrt-22.03
Álvaro Fernández Rojas 9 years ago
parent
commit
f535396cd9
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      libs/libftdi/Makefile
  2. +11
    -0
      libs/libftdi/patches/102-fix-cmake-include-examples.patch

+ 1
- 1
libs/libftdi/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libftdi
PKG_VERSION:=0.20
PKG_RELEASE:=3
PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.intra2net.com/en/developer/libftdi/download/


+ 11
- 0
libs/libftdi/patches/102-fix-cmake-include-examples.patch View File

@ -0,0 +1,11 @@
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -2,7 +2,7 @@ option(EXAMPLES "Build example programs"
if (EXAMPLES)
# Includes
- include( ${CMAKE_CURRENT_SOURCE_DIR}
+ include_directories( ${CMAKE_CURRENT_SOURCE_DIR}
${CMAKE_CURRENT_BINARY_DIR}
)

Loading…
Cancel
Save