Browse Source

libshout: Fix OpenSSL 1.1.0 without deprecated APIs

Previous patch was incomplete and broke with deprecated APIs
disabled.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 6 years ago
parent
commit
f51d3846d8
2 changed files with 9 additions and 3 deletions
  1. +1
    -1
      libs/libshout/Makefile
  2. +8
    -2
      libs/libshout/patches/150-openssl-1.1.patch

+ 1
- 1
libs/libshout/Makefile View File

@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libshout
PKG_VERSION:=2.4.1
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz


+ 8
- 2
libs/libshout/patches/150-openssl-1.1.patch View File

@ -1,6 +1,8 @@
diff --git a/src/tls.c b/src/tls.c
index 4562c73..f946946 100644
--- a/src/tls.c
+++ b/src/tls.c
@@ -63,10 +63,12 @@ static inline int tls_setup(shout_tls_t
@@ -63,12 +63,16 @@ static inline int tls_setup(shout_tls_t *tls)
{
SSL_METHOD *meth;
@ -9,7 +11,11 @@
SSL_load_error_strings();
SSLeay_add_all_algorithms();
SSLeay_add_ssl_algorithms();
+#endif
meth = TLSv1_client_method();
+#else
+ meth = TLS_client_method();
+#endif
if (!meth)
goto error;

Loading…
Cancel
Save