|
|
@ -0,0 +1,38 @@ |
|
|
|
From 28c0f8895e4ac270b56b5c7e8089dd2417bc4e3c Mon Sep 17 00:00:00 2001 |
|
|
|
From: Alex Gaynor <alex.gaynor@gmail.com> |
|
|
|
Date: Sun, 20 May 2018 18:46:32 -0400 |
|
|
|
Subject: [PATCH] cmake: Add an option to enable/disable building of |
|
|
|
executables |
|
|
|
|
|
|
|
Add the CMake option PNG_EXECUTABLES (on by default) in order to |
|
|
|
allow or disallow the building of non-essential executable programs |
|
|
|
associated with libpng. |
|
|
|
|
|
|
|
Contributed-by: Alex Gaynor <alex.gaynor@gmail.com> |
|
|
|
Contributed-by: Cosmin Truta <ctruta@gmail.com> |
|
|
|
Signed-off-by: Cosmin Truta <ctruta@gmail.com> |
|
|
|
---
|
|
|
|
CMakeLists.txt | 6 ++++-- |
|
|
|
1 file changed, 4 insertions(+), 2 deletions(-) |
|
|
|
|
|
|
|
--- a/CMakeLists.txt
|
|
|
|
+++ b/CMakeLists.txt
|
|
|
|
@@ -53,7 +53,8 @@ endif()
|
|
|
|
# COMMAND LINE OPTIONS |
|
|
|
option(PNG_SHARED "Build shared lib" ON) |
|
|
|
option(PNG_STATIC "Build static lib" ON) |
|
|
|
-option(PNG_TESTS "Build libpng tests" ON)
|
|
|
|
+option(PNG_EXECUTABLES "Build libpng executables" ON)
|
|
|
|
+option(PNG_TESTS "Build libpng tests" ON)
|
|
|
|
|
|
|
|
# Many more configuration options could be added here |
|
|
|
option(PNG_FRAMEWORK "Build OS X framework" OFF) |
|
|
|
@@ -747,7 +748,7 @@ if(PNG_TESTS AND PNG_SHARED)
|
|
|
|
png_add_test(NAME pngimage-full COMMAND pngimage OPTIONS --exhaustive --list-combos --log FILES ${PNGSUITE_PNGS}) |
|
|
|
endif() |
|
|
|
|
|
|
|
-if(PNG_SHARED)
|
|
|
|
+if(PNG_SHARED AND PNG_EXECUTABLES)
|
|
|
|
add_executable(pngfix ${pngfix_sources}) |
|
|
|
target_link_libraries(pngfix png) |
|
|
|
set(PNG_BIN_TARGETS pngfix) |