Browse Source

gnutls: updated to gnutls 3.2.16

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
lilik-openwrt-22.03
Nikos Mavrogiannopoulos 11 years ago
parent
commit
f2b27cdef2
2 changed files with 2 additions and 30 deletions
  1. +2
    -2
      libs/gnutls/Makefile
  2. +0
    -28
      libs/gnutls/patches/0001-nn-hash.patch

+ 2
- 2
libs/gnutls/Makefile View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=gnutls PKG_NAME:=gnutls
PKG_VERSION:=3.2.15
PKG_VERSION:=3.2.16
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=ftp://ftp.gnutls.org/gcrypt/gnutls/v3.2 PKG_SOURCE_URL:=ftp://ftp.gnutls.org/gcrypt/gnutls/v3.2
PKG_MD5SUM:=ec3b06f80e312137386c5d322183ca5a
PKG_MD5SUM:=d9a3fb49121b49bc332bfe9c3f49b005
PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org> PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
PKG_INSTALL:=1 PKG_INSTALL:=1


+ 0
- 28
libs/gnutls/patches/0001-nn-hash.patch View File

@ -1,28 +0,0 @@
diff --git a/lib/accelerated/x86/x86-common.h b/lib/accelerated/x86/x86-common.h
index 03fc8de..647c7d6 100644
--- a/lib/accelerated/x86/x86-common.h
+++ b/lib/accelerated/x86/x86-common.h
@@ -29,11 +29,13 @@ extern unsigned int _gnutls_x86_cpuid_s[4];
void gnutls_cpuid(unsigned int func, unsigned int *ax, unsigned int *bx,
unsigned int *cx, unsigned int *dx);
-#ifdef ASM_X86_32
+# ifdef ASM_X86_32
unsigned int gnutls_have_cpuid(void);
-#else
-#define gnutls_have_cpuid() 1
-#endif /* ASM_X86_32 */
+# else
+# define gnutls_have_cpuid() 1
+# endif /* ASM_X86_32 */
+
+#endif
#define NN_HASH(name, update_func, digest_func, NAME) { \
#name, \
@@ -44,5 +46,3 @@ unsigned int gnutls_have_cpuid(void);
(nettle_hash_update_func *) update_func, \
(nettle_hash_digest_func *) digest_func \
}
-
-#endif

Loading…
Cancel
Save