Browse Source
Merge pull request #15945 from neheb/tv
tvheadend: fix compilation with GCC 9 and 10
lilik-openwrt-22.03
Rosen Penev
3 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
10 additions and
1 deletions
-
multimedia/tvheadend/Makefile
-
multimedia/tvheadend/patches/040-fortify.patch
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
|
PKG_NAME:=tvheadend |
|
|
PKG_NAME:=tvheadend |
|
|
PKG_VERSION:=4.0.10 |
|
|
PKG_VERSION:=4.0.10 |
|
|
PKG_RELEASE:=5 |
|
|
|
|
|
|
|
|
PKG_RELEASE:=6 |
|
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
PKG_SOURCE_URL:=https://codeload.github.com/tvheadend/tvheadend/tar.gz/v$(PKG_VERSION)? |
|
|
PKG_SOURCE_URL:=https://codeload.github.com/tvheadend/tvheadend/tar.gz/v$(PKG_VERSION)? |
|
|
|
@ -0,0 +1,9 @@ |
|
|
|
|
|
--- a/src/intlconv.c
|
|
|
|
|
|
+++ b/src/intlconv.c
|
|
|
|
|
|
@@ -1,3 +1,6 @@
|
|
|
|
|
|
+#ifndef _GNU_SOURCE
|
|
|
|
|
|
+#define _GNU_SOURCE
|
|
|
|
|
|
+#endif
|
|
|
|
|
|
#include <iconv.h> |
|
|
|
|
|
#include "tvheadend.h" |
|
|
|
|
|
#include "intlconv.h" |