Browse Source

libowfat: fix compilation under GCC10

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
committed by Daniel Golle
parent
commit
f0db39bf0e
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      libs/libowfat/Makefile
  2. +11
    -0
      libs/libowfat/patches/010-gcc10.patch

+ 1
- 1
libs/libowfat/Makefile View File

@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libowfat
PKG_VERSION:=0.32
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.fefe.de/libowfat


+ 11
- 0
libs/libowfat/patches/010-gcc10.patch View File

@ -0,0 +1,11 @@
--- a/io_internal.h
+++ b/io_internal.h
@@ -83,7 +83,7 @@ my_extern array io_pollfds;
my_extern long first_readable;
my_extern long first_writeable;
-my_extern long first_deferred;
+extern long first_deferred;
my_extern enum __io_waitmode {
UNDECIDED,

Loading…
Cancel
Save