Browse Source
debootstrap: update to 1.0.118
Added _GNU_SOURCE define to fix compilation warning.
Added patch to fix uclient-fetch as it does not support -nv.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev
5 years ago
No known key found for this signature in database
GPG Key ID: 36D31CFA845F0E3B
3 changed files with
13 additions and
2 deletions
admin/debootstrap/Makefile
admin/debootstrap/files/pkgdetails.c
admin/debootstrap/patches/010-no-nvswitch.patch
@ -9,12 +9,12 @@
i n c l u d e $( TOPDIR ) / r u l e s . m k
PKG_NAME := debootstrap
PKG_VERSION := 1.0.116
PKG_VERSION := 1.0.118
PKG_RELEASE := 1
PKG_SOURCE := $( PKG_NAME) -udeb_$( PKG_VERSION) _all.udeb
PKG_SOURCE_URL := http://ftp.debian.org/debian/pool/main/d/debootstrap
PKG_HASH := 2325cbad6fac19cec7db34cff8fc06f9d9781862621b6e91f10549cf7c7c66af
PKG_HASH := fad9b7968676c1f4a680e2b07c2b2859f5513ea94425ad3247189eb81bdb51a6
PKG_MAINTAINER := Daniel Golle <daniel@makrotopia.org>
PKG_LICENSE := Unique
@ -1,3 +1,4 @@
# define _GNU_SOURCE
# include <stdio.h>
# include <stdlib.h>
# include <string.h>
@ -0,0 +1,10 @@
--- a/usr/share/debootstrap/functions
+++ b/usr/share/debootstrap/functions
@@ -77,7 +77,6 @@ progress_next () {
}
wgetprogress () {
- [ ! "$VERBOSE" ] && NVSWITCH="-nv"
local ret=0
if [ "$USE_DEBIANINSTALLER_INTERACTION" ] && [ "$PROGRESS_NEXT" ]; then
# The exit status of a pipeline is that of the last command in