Browse Source

Merge pull request #9386 from neheb/ke2

kea: Fix compilation without deprecated OpenSSL APIs
lilik-openwrt-22.03
Rosen Penev 5 years ago
committed by GitHub
parent
commit
eeff4f6376
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      net/kea/Makefile
  2. +11
    -0
      net/kea/patches/010-openssl-deprecated.patch

+ 1
- 1
net/kea/Makefile View File

@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kea
PKG_VERSION:=1.5.0
PKG_RELEASE:=4
PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://ftp.isc.org/isc/kea/$(PKG_VERSION)


+ 11
- 0
net/kea/patches/010-openssl-deprecated.patch View File

@ -0,0 +1,11 @@
--- a/src/lib/cryptolink/openssl_link.cc
+++ b/src/lib/cryptolink/openssl_link.cc
@@ -79,7 +79,7 @@ CryptoLink::initialize() {
std::string
CryptoLink::getVersion() {
- return (SSLeay_version(SSLEAY_VERSION));
+ return (OpenSSL_version(OPENSSL_VERSION));
}
} // namespace cryptolink

Loading…
Cancel
Save