Browse Source

Merge pull request #6130 from MikePetullo/dovecot

dovecot: add GSSAPI module
lilik-openwrt-22.03
Hannu Nyman 6 years ago
committed by GitHub
parent
commit
eca7da688c
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 32 additions and 8 deletions
  1. +8
    -2
      mail/dovecot/Makefile
  2. +24
    -6
      mail/dovecot/patches/001-configure_in.patch

+ 8
- 2
mail/dovecot/Makefile View File

@ -20,6 +20,7 @@ PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
PKG_BUILD_DEPENDS:=libiconv
PKG_CONFIG_DEPENDS:= \
CONFIG_DOVECOT_GSSAPI \
CONFIG_DOVECOT_LDAP \
CONFIG_DOVECOT_MYSQL \
CONFIG_DOVECOT_PGSQL \
@ -34,7 +35,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/dovecot
SECTION:=mail
CATEGORY:=Mail
DEPENDS:=+DOVECOT_LDAP:libopenldap +DOVECOT_MYSQL:libmysqlclient +DOVECOT_PGSQL:libpq +DOVECOT_SQLITE:libsqlite3 +libopenssl +librt +zlib +libbz2 +libcap +DOVECOT_ICU:icu
DEPENDS:=+DOVECOT_GSSAPI:krb5-libs +DOVECOT_LDAP:libopenldap +DOVECOT_MYSQL:libmysqlclient +DOVECOT_PGSQL:libpq +DOVECOT_SQLITE:libsqlite3 +libopenssl +librt +zlib +libbz2 +libcap +DOVECOT_ICU:icu
TITLE:=An IMAP and POP3 daemon
URL:=http://www.dovecot.org/
USERID:=dovecot=59:dovecot=59
@ -48,6 +49,11 @@ endef
define Package/dovecot/config
menu "Select dovecot build options"
depends on PACKAGE_dovecot
config DOVECOT_GSSAPI
bool "GSSAPI support"
default n
help
Implements GSSAPI support in dovecot.
config DOVECOT_LDAP
bool "LDAP support"
default n
@ -89,12 +95,12 @@ define Package/dovecot-utils
endef
CONFIGURE_ARGS += \
--without-gssapi \
--without-pam \
--with-moduledir=/usr/lib/dovecot/modules \
--with-notify=dnotify \
--without-lzma \
--without-lz4 \
$(if $(CONFIG_DOVECOT_GSSAPI),--with-gssapi=yes,--with-gssapi=no) \
$(if $(CONFIG_DOVECOT_LDAP),--with-ldap=yes,--with-ldap=no) \
$(if $(CONFIG_DOVECOT_MYSQL),--with-mysql=yes,--with-mysql=no) \
$(if $(CONFIG_DOVECOT_PGSQL),--with-pgsql=yes,--with-pgsql=no) \


+ 24
- 6
mail/dovecot/patches/001-configure_in.patch View File

@ -1,18 +1,19 @@
--- a/configure.ac
+++ b/configure.ac
@@ -488,9 +488,9 @@ have_ioloop=no
diff -u --recursive dovecot-2.2.35-vanilla/configure.ac dovecot-2.2.35/configure.ac
--- dovecot-2.2.35-vanilla/configure.ac 2018-03-19 08:22:42.000000000 -0400
+++ dovecot-2.2.35/configure.ac 2018-05-25 10:41:36.122503480 -0400
@@ -490,9 +490,10 @@
if test "$ioloop" = "best" || test "$ioloop" = "epoll"; then
AC_CACHE_CHECK([whether we can use epoll],i_cv_epoll_works,[
- AC_TRY_RUN([
+ AC_TRY_LINK([
#include <sys/epoll.h>
-
+ ], [
int main()
{
return epoll_create(5) < 1;
@@ -594,7 +594,7 @@ fi
@@ -596,7 +597,7 @@
dnl * Old glibcs have broken posix_fallocate(). Make sure not to use it.
dnl * It may also be broken in AIX.
AC_CACHE_CHECK([whether posix_fallocate() works],i_cv_posix_fallocate_works,[
@ -21,7 +22,7 @@
#define _XOPEN_SOURCE 600
#include <stdio.h>
#include <stdlib.h>
@@ -603,6 +603,7 @@ AC_CACHE_CHECK([whether posix_fallocate(
@@ -605,6 +606,7 @@
#if defined(__GLIBC__) && (__GLIBC__ < 2 || __GLIBC_MINOR__ < 7)
possibly broken posix_fallocate
#endif
@ -29,3 +30,20 @@
int main() {
int fd = creat("conftest.temp", 0600);
int ret;
@@ -2059,7 +2061,7 @@
# does the kerberos library support SPNEGO?
AC_CACHE_CHECK([whether GSSAPI supports SPNEGO],i_cv_gssapi_spnego,[
- AC_TRY_RUN([
+ AC_TRY_LINK([
#ifdef HAVE_GSSAPI_H
# include <gssapi.h>
#else
@@ -2067,6 +2069,7 @@
#endif
#include <krb5.h>
#include <string.h>
+ ], [
int main(void) {
OM_uint32 minor_status;
gss_OID_set mech_set;

Loading…
Cancel
Save