Browse Source

git: configure as cross compiling

Previously, ./configure was running checking local system and not
OpenWRT target. This would avoid any configure test about OpenWRT
libraries.

With a patch in configure, non cross-compiling-friend test are
ignored and Makefile can use default configure.

As side effect, git commands are now at /usr/lib/git-core and not
/usr/libexec/git-core.

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
lilik-openwrt-22.03
Luiz Angelo Daros de Luca 10 years ago
parent
commit
e9eea78910
2 changed files with 36 additions and 5 deletions
  1. +4
    -5
      net/git/Makefile
  2. +32
    -0
      net/git/patches/300-configure_for_crosscompiling

+ 4
- 5
net/git/Makefile View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2009-2014 OpenWrt.org
# Copyright (C) 2009-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=git
PKG_VERSION:=2.3.0
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/scm/git/
@ -17,6 +17,7 @@ PKG_MD5SUM:=e5880760d1f43f4f49b3bf94b9046eee
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
@ -57,9 +58,7 @@ define Build/Configure
$(MAKE) -C $(PKG_BUILD_DIR) \
configure
( cd $(PKG_BUILD_DIR); \
./configure --prefix=/usr \
);
$(call Build/Configure/Default,)
endef
define Package/git/install


+ 32
- 0
net/git/patches/300-configure_for_crosscompiling View File

@ -0,0 +1,32 @@
--- git-2.3.0/configure.ac.old 2015-03-08 01:19:33.675810197 -0300
+++ git-2.3.0/configure.ac 2015-03-08 01:27:10.688033125 -0300
@@ -844,7 +844,8 @@
FILE *f = fopen(".", "r");
return f && fread(&c, 1, 1, f)]])],
[ac_cv_fread_reads_directories=no],
- [ac_cv_fread_reads_directories=yes])
+ [ac_cv_fread_reads_directories=yes],
+ [ac_cv_fread_reads_directories=no])
])
if test $ac_cv_fread_reads_directories = yes; then
FREAD_READS_DIRECTORIES=UnfortunatelyYes
@@ -878,7 +879,8 @@
if (snprintf(buf, 3, "%s", "12345") != 5
|| strcmp(buf, "12")) return 1]])],
[ac_cv_snprintf_returns_bogus=no],
- [ac_cv_snprintf_returns_bogus=yes])
+ [ac_cv_snprintf_returns_bogus=yes],
+ [ac_cv_snprintf_returns_bogus=no])
])
if test $ac_cv_snprintf_returns_bogus = yes; then
SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes
@@ -901,7 +903,8 @@
#endif
]),
[ac_cv_sane_mode_bits=yes],
- [ac_cv_sane_mode_bits=no])
+ [ac_cv_sane_mode_bits=no],
+ [ac_cv_sane_mode_bits=yes])
])
if test $ac_cv_sane_mode_bits = yes; then
NEEDS_MODE_TRANSLATION=

Loading…
Cancel
Save