Browse Source

php7-pecl-http: fix build when host has php installed (refs #3149)

When php is installed on the host system, then the configure tries
to obtain from this binary whether some extensions are available.
This prevents the cross build when the desired extensions are not
present - which is the usual case.

So add a patch to prevent configure from doing this - we give
this information via environment variable during build already.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lilik-openwrt-22.03
Michael Heimpold 8 years ago
parent
commit
e99e704eb4
2 changed files with 23 additions and 1 deletions
  1. +1
    -1
      lang/php7-pecl-http/Makefile
  2. +22
    -0
      lang/php7-pecl-http/patches/100_config9-m4.patch

+ 1
- 1
lang/php7-pecl-http/Makefile View File

@ -9,7 +9,7 @@ PECL_NAME:=pecl_http
PECL_LONGNAME:=Extended HTTP Support
PKG_VERSION:=3.0.1
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_MD5SUM:=042c97314c180f6473338f0c5d35fabd
PKG_NAME:=php7-pecl-http


+ 22
- 0
lang/php7-pecl-http/patches/100_config9-m4.patch View File

@ -0,0 +1,22 @@
--- a/config9.m4 2016-09-08 21:39:18.000000000 +0200
+++ b/config9.m4 2016-09-08 21:42:35.066903251 +0200
@@ -71,18 +71,7 @@
extname=$1
haveext=$[PHP_]translit($1,a-z_-,A-Z__)
AC_MSG_CHECKING([for ext/$extname support])
- if test -x "$PHP_EXECUTABLE"; then
- grepext=`$PHP_EXECUTABLE -m | $EGREP ^$extname\$`
- if test "$grepext" = "$extname"; then
- [PHP_HTTP_HAVE_EXT_]translit($1,a-z_-,A-Z__)=1
- AC_MSG_RESULT([yes])
- $2
- else
- [PHP_HTTP_HAVE_EXT_]translit($1,a-z_-,A-Z__)=
- AC_MSG_RESULT([no])
- $3
- fi
- elif test "$haveext" != "no" && test "x$haveext" != "x"; then
+ if test "$haveext" != "no" && test "x$haveext" != "x"; then
[PHP_HTTP_HAVE_EXT_]translit($1,a-z_-,A-Z__)=1
AC_MSG_RESULT([yes])
$2

Loading…
Cancel
Save