Browse Source

Merge pull request #9674 from neheb/lcd2

lcdproc: Fix non x86 platforms on musl
lilik-openwrt-22.03
Rosen Penev 5 years ago
committed by GitHub
parent
commit
e91ef90bb2
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 14 additions and 11 deletions
  1. +3
    -11
      utils/lcdproc/Makefile
  2. +11
    -0
      utils/lcdproc/patches/110-in-outb.patch

+ 3
- 11
utils/lcdproc/Makefile View File

@ -9,18 +9,17 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lcdproc
PKG_VERSION:=0.5.9
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/lcdproc/lcdproc/releases/download/v$(PKG_VERSION)/
PKG_HASH:=d48a915496c96ff775b377d2222de3150ae5172bfb84a6ec9f9ceab962f97b83
PKG_MAINTAINER:=Harald Geyer <harald@ccbib.org>, \
Philip Prindeville <philipp@redfish-solutions.com>
PKG_LICENSE:=GPL-2.0
PKG_LICENSE:=GPL-2.0-only
PKG_LICENSE_FILES:=COPYING
PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
define Package/lcdproc/Default
@ -109,10 +108,6 @@ This package contains display drivers with external dependencies:
$(LCDPROC_OTHER_DRIVERS_TEXT)
endef
# not everything groks --disable-nls
DISABLE_NLS:=
CONFIGURE_ARGS += \
--disable-libX11 \
--disable-libhid \
@ -120,9 +115,6 @@ CONFIGURE_ARGS += \
--disable-freetype \
--enable-drivers='all,!g15,!g15driver,!glcdlib,!irman,!lirc,!mdm166a,!mx5000,!svga,!xosd'
# can't use -Wformat=2 because MUSL is somewhat broken
TARGET_CFLAGS+=-Wall
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)"


+ 11
- 0
utils/lcdproc/patches/110-in-outb.patch View File

@ -0,0 +1,11 @@
--- a/server/drivers/port.h
+++ b/server/drivers/port.h
@@ -94,7 +94,7 @@ static inline int port_deny_multiple(unsigned short port, unsigned short count);
/* ---------------------------- Linux ------------------------------------ */
/* Use ioperm, inb and outb in <sys/io.h> (Linux) */
/* And iopl for higher addresses of PCI LPT cards */
-#if defined HAVE_IOPERM
+#if defined(__GLIBC__) || (defined(__x86__) || defined(__x86_64__))
/* Glibc2 and Glibc1 */
# ifdef HAVE_SYS_IO_H

Loading…
Cancel
Save