Browse Source

mosquitto: upgrade to version 1.4.4

Drop patch now included upstream.

More information: http://mosquitto.org/2015/09/version-1-4-4-released/

Signed-off-by: Karl Palsson <karlp@tweak.net.au>
lilik-openwrt-22.03
Karl Palsson 9 years ago
parent
commit
e7bd3fbe21
2 changed files with 3 additions and 17 deletions
  1. +3
    -3
      net/mosquitto/Makefile
  2. +0
    -14
      net/mosquitto/patches/001-free-counting-bug-475707.patch

+ 3
- 3
net/mosquitto/Makefile View File

@ -9,14 +9,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mosquitto
PKG_VERSION:=1.4.3
PKG_RELEASE:=2
PKG_VERSION:=1.4.4
PKG_RELEASE:=1
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.txt
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://mosquitto.org/files/source/
PKG_MD5SUM:=1c1c750525546bc13d8d72e56a0742a7
PKG_MD5SUM:=89a57f11cdfec140fa21fe3d4493b2ca
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk


+ 0
- 14
net/mosquitto/patches/001-free-counting-bug-475707.patch View File

@ -1,14 +0,0 @@
diff --git a/lib/memory_mosq.c b/lib/memory_mosq.c
index b1f5bfd..4d8217d 100644
--- a/lib/memory_mosq.c
+++ b/lib/memory_mosq.c
@@ -54,6 +54,9 @@ void *mosquitto__calloc(size_t nmemb, size_t size)
void mosquitto__free(void *mem)
{
#ifdef REAL_WITH_MEMORY_TRACKING
+ if(!mem){
+ return;
+ }
memcount -= malloc_usable_size(mem);
#endif
free(mem);

Loading…
Cancel
Save