Browse Source

keepalived: upgrade to version 1.2.19

Dropped patches, unrequired.
There is a newer version released, but I cannot vouch for it yet.
We've been using this one for about a year now.

Since, I only recently became maintainer of `keepalived`, I will
push this as the current stable one, and start using a newer
version internally, before releasing it to the public.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lilik-openwrt-22.03
Alexandru Ardelean 8 years ago
parent
commit
e73964fa8f
3 changed files with 4 additions and 56 deletions
  1. +4
    -3
      net/keepalived/Makefile
  2. +0
    -10
      net/keepalived/patches/100-musl-compat.patch
  3. +0
    -43
      net/keepalived/patches/101-update-struct-msghdr.patch

+ 4
- 3
net/keepalived/Makefile View File

@ -8,12 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=keepalived
PKG_VERSION:=1.2.16
PKG_RELEASE:=3
PKG_VERSION:=1.2.19
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:= http://www.keepalived.org/software
PKG_MD5SUM:=f834ab2cfc2e7300edf1bafaf4a5d83e
PKG_MD5SUM:=5c98b06639dd50a6bff76901b53febb6
PKG_HASH:=32fbae732c1cd854cacd7a930d4a26f5bad6372cdecb5e3139f0c17e87493853
PKG_LICENSE:=GPL-2.0+
PKG_LICENSE_FILES:=COPYING


+ 0
- 10
net/keepalived/patches/100-musl-compat.patch View File

@ -1,10 +0,0 @@
--- a/lib/utils.h
+++ b/lib/utils.h
@@ -31,6 +31,7 @@
#include <arpa/inet.h>
#include <arpa/nameser.h>
#include <sys/param.h>
+#include <sys/types.h>
#include <sys/utsname.h>
#include <netdb.h>

+ 0
- 43
net/keepalived/patches/101-update-struct-msghdr.patch View File

@ -1,43 +0,0 @@
From 0fc8dfa7ef479220b2a27901c5c69add6e13debd Mon Sep 17 00:00:00 2001
From: Stijn Tintel <stijn@linux-ipv6.be>
Date: Tue, 10 May 2016 04:26:31 +0300
Subject: [PATCH] vrrp: update struct msghdr
The vrrp netlink code assumes an order for the members of struct msghdr.
This breaks recvmsg and sendmsg with musl libc on mips64. Fix this by
using designated initializers instead.
---
keepalived/vrrp/vrrp_netlink.c | 15 ++++++++++++---
1 file changed, 12 insertions(+), 3 deletions(-)
--- a/keepalived/vrrp/vrrp_netlink.c
+++ b/keepalived/vrrp/vrrp_netlink.c
@@ -276,8 +276,12 @@ netlink_parse_info(int (*filter) (struct
char buf[4096];
struct iovec iov = { buf, sizeof buf };
struct sockaddr_nl snl;
- struct msghdr msg =
- { (void *) &snl, sizeof snl, &iov, 1, NULL, 0, 0 };
+ struct msghdr msg = {
+ .msg_name = &snl,
+ .msg_namelen = sizeof(snl),
+ .msg_iov = &iov,
+ .msg_iovlen = 1,
+ };
struct nlmsghdr *h;
status = recvmsg(nl->fd, &msg, 0);
@@ -386,7 +390,12 @@ netlink_talk(nl_handle_t *nl, struct nlm
int ret, flags;
struct sockaddr_nl snl;
struct iovec iov = { (void *) n, n->nlmsg_len };
- struct msghdr msg = { (void *) &snl, sizeof snl, &iov, 1, NULL, 0, 0 };
+ struct msghdr msg = {
+ .msg_name = &snl,
+ .msg_namelen = sizeof(snl),
+ .msg_iov = &iov,
+ .msg_iovlen = 1,
+ };
memset(&snl, 0, sizeof snl);
snl.nl_family = AF_NETLINK;

Loading…
Cancel
Save